dev-perl/Crypt-SMIME: add libressl support
authorJulian Ospald <hasufell@gentoo.org>
Sun, 20 Sep 2015 14:43:08 +0000 (16:43 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Sun, 20 Sep 2015 16:37:58 +0000 (18:37 +0200)
dev-perl/Crypt-SMIME/Crypt-SMIME-0.150.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Crypt-SMIME/Crypt-SMIME-0.150.0-r1.ebuild b/dev-perl/Crypt-SMIME/Crypt-SMIME-0.150.0-r1.ebuild
new file mode 100644 (file)
index 0000000..22f8f24
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MIKAGE
+MODULE_VERSION=0.15
+inherit perl-module
+
+DESCRIPTION="S/MIME message signing, verification, encryption and decryption"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl test"
+
+RDEPEND="
+       !libressl? ( dev-libs/openssl:0 )
+       libressl? ( dev-libs/libressl )
+       virtual/perl-XSLoader
+"
+DEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       dev-perl/extutils-pkgconfig
+       dev-perl/ExtUtils-CChecker
+       test? (
+               dev-perl/Test-Exception
+               virtual/perl-Test-Simple
+               >=dev-perl/Test-Taint-1.60.0
+               dev-perl/Test-Dependencies
+               >=dev-perl/Test-Pod-1.140.0
+               >=dev-perl/Test-Pod-Coverage-1.40.0
+       )
+"
+
+SRC_TEST=do