dev-python/sunpy: remove last-rited pkg
authorMikle Kolyada <zlogene@gentoo.org>
Sat, 28 Dec 2019 16:35:13 +0000 (19:35 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sat, 28 Dec 2019 16:35:13 +0000 (19:35 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
dev-python/sunpy/Manifest [deleted file]
dev-python/sunpy/metadata.xml [deleted file]
dev-python/sunpy/sunpy-0.8.0.ebuild [deleted file]

diff --git a/dev-python/sunpy/Manifest b/dev-python/sunpy/Manifest
deleted file mode 100644 (file)
index 3d3b7f0..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST sunpy-0.8.0.tar.gz 6336169 BLAKE2B 554e64c27bb2c9c68629401bef83da3248a841c728d040fbda77465f04bd2c6a2cfb48f3a5df2bb0b15a306d6664f635aac7342e1135cf3bc61e1436a4db934a SHA512 7996fdcb47e4143159253180b2250ea7ac4aa8fecf8d3f1eae930da018d39ce4e663c843b4b0532e900f97d2bc9fadfd7c17837f4f045634820059a5af802eda
diff --git a/dev-python/sunpy/metadata.xml b/dev-python/sunpy/metadata.xml
deleted file mode 100644 (file)
index 1915944..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-  <maintainer type="project">
-    <email>sci-astronomy@gentoo.org</email>
-    <name>Gentoo Astronomy Project</name>
-  </maintainer>
-  <longdescription lang="en">
-    SunPy is a community-developed free and open-source software package for
-    solar physics. SunPy is meant to be a free alternative to the SolarSoft data
-    analysis environment. The aim of the SunPy project is to provide the
-    software tools necessary so that anyone can analyze solar data.
-  </longdescription>
-  <upstream>
-    <remote-id type="pypi">sunpy</remote-id>
-    <remote-id type="github">sunpy/sunpy</remote-id>
-  </upstream>
-</pkgmetadata>
diff --git a/dev-python/sunpy/sunpy-0.8.0.ebuild b/dev-python/sunpy/sunpy-0.8.0.ebuild
deleted file mode 100644 (file)
index 7a6bdc9..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Software library for solar physics based on Python"
-HOMEPAGE="https://sunpy.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="jpeg2k test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/astropy-2[${PYTHON_USEDEP}]
-       dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
-       dev-python/matplotlib[${PYTHON_USEDEP}]
-       >=dev-python/numpy-1.11[${PYTHON_USEDEP}]
-       dev-python/pandas[${PYTHON_USEDEP}]
-       dev-python/requests[${PYTHON_USEDEP}]
-       dev-python/sqlalchemy[${PYTHON_USEDEP}]
-       dev-python/suds[${PYTHON_USEDEP}]
-       sci-libs/scipy[${PYTHON_USEDEP}]
-       sci-libs/scikits_image[${PYTHON_USEDEP}]
-       jpeg2k? ( dev-python/glymur[${PYTHON_USEDEP}] )
-"
-DEPEND="${RDEPEND}
-       dev-python/astropy-helpers[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/hypothesis[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-mock[${PYTHON_USEDEP}]
-               dev-python/pytest-mpl[${PYTHON_USEDEP}]
-       )
-"
-
-python_prepare_all() {
-       # use system astropy-helpers instead of bundled one
-       sed -i -e '/auto_use/s/True/False/' setup.cfg || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       "${PYTHON}" -m pytest sunpy -k "not figure and not online" || die
-}