sys-cluster/swift: migration to user packages
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 17 Mar 2020 13:49:11 +0000 (08:49 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 17 Mar 2020 13:49:11 +0000 (08:49 -0500)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
RepoMan-Options: --force
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
sys-cluster/swift/metadata.xml
sys-cluster/swift/swift-2.23.1-r2.ebuild [moved from sys-cluster/swift/swift-2.23.1-r1.ebuild with 93% similarity]

index 14aa35f3e4a6d77681cdb148e33aac6c31eedf2b..6a12c88d2a7662d40ed7c3c7e655796bdf3871c0 100644 (file)
     <email>openstack@gentoo.org</email>
     <name>Openstack</name>
   </maintainer>
-  <longdescription lang="en">
-    Swift is a highly available, distributed, eventually consistent object/blob
-  store.
-  </longdescription>
   <upstream>
     <remote-id type="launchpad">swift</remote-id>
   </upstream>
similarity index 93%
rename from sys-cluster/swift/swift-2.23.1-r1.ebuild
rename to sys-cluster/swift/swift-2.23.1-r2.ebuild
index 81130d620e211434210a558cd2172300650b2a05..0209967c131d54ae5003bb53c5bbabd815e71f01 100644 (file)
@@ -1,10 +1,10 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 PYTHON_COMPAT=( python3_6 python3_7 )
 
-inherit distutils-r1 eutils linux-info user
+inherit distutils-r1 eutils linux-info
 
 DESCRIPTION="A highly available, distributed, and eventually consistent object/blob store"
 HOMEPAGE="https://launchpad.net/swift"
@@ -19,7 +19,7 @@ fi
 
 LICENSE="Apache-2.0"
 SLOT="0"
-IUSE="account container doc +memcached object proxy"
+IUSE="account container doc +memcached +object proxy"
 REQUIRED_USE="|| ( proxy account container object )"
 
 CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
@@ -40,7 +40,9 @@ RDEPEND="
        >=dev-python/PyECLib-1.3.1[${PYTHON_USEDEP}]
        >=dev-python/cryptography-2.0.2[${PYTHON_USEDEP}]
        memcached? ( net-misc/memcached )
-       net-misc/rsync[xattr]"
+       net-misc/rsync[xattr]
+       acct-user/swift
+       acct-group/swift"
 
 pkg_pretend() {
        linux-info_pkg_setup
@@ -54,11 +56,6 @@ pkg_pretend() {
        fi
 }
 
-pkg_setup() {
-       enewuser swift
-       enewgroup swift
-}
-
 src_prepare() {
        sed -i 's/xattr/pyxattr/g' requirements.txt || die
        sed -i '/^hacking/d' test-requirements.txt || die
@@ -87,8 +84,7 @@ python_install_all() {
                newinitd "${FILESDIR}/swift-proxy.initd" "swift-proxy"
                newins "etc/proxy-server.conf-sample" "proxy-server.conf"
                if use memcached; then
-                       sed -i '/depend/a\
-    need memcached' "${D}/etc/init.d/swift-proxy"
+                       sed -i '/depend/a\    need memcached' "${D}/etc/init.d/swift-proxy"
                fi
        fi
        if use account; then