sys-process/cronie: Bump to version 1.5.5
authorLars Wendler <polynomial-c@gentoo.org>
Fri, 1 Nov 2019 02:54:12 +0000 (03:54 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Sat, 2 Nov 2019 09:46:21 +0000 (10:46 +0100)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-process/cronie/Manifest
sys-process/cronie/cronie-1.5.5.ebuild [new file with mode: 0644]
sys-process/cronie/files/cronie-crontab

index caf878723a890f37318beaedc6a431ca9bc15cff..85685348109eb794d3131ae6fd66e9d477ca7bea 100644 (file)
@@ -1 +1,2 @@
 DIST cronie-1.5.4.tar.gz 122452 BLAKE2B 042961390807c22aa1db3ab592470538d9a348d33fee8f088dfa20e45ee72c72d9502bf5eb5a957494c55d99a6705b94774442f5a2fb06eeab1aa0b0e1a4d6ae SHA512 40a8cd750bc18dcb264e88cf049b0ea66f053b7b6cc10f38fd4f4e6b912871f41ce7ad126521a08203e81c00846e001016b47da3c5e8730a7b49fc970d7b2a6a
+DIST cronie-1.5.5.tar.gz 124642 BLAKE2B 19bb690a2ae66b9b99dcd0536c115fbdf46c0f1c58922e08fb31d9789df3358438001bd4b6b55d16e99e3927364c618ac22cb04661db1245d09709fcb58eef1e SHA512 88b0e877e5b36a0063b37a6ce82133117c95ebd4435ce843e09c6247ac50f36c66503b850aafa75512fab07d46a110ddfdf52e7e984638ed794588e338547166
diff --git a/sys-process/cronie/cronie-1.5.5.ebuild b/sys-process/cronie/cronie-1.5.5.ebuild
new file mode 100644 (file)
index 0000000..33cb53b
--- /dev/null
@@ -0,0 +1,112 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools cron flag-o-matic pam systemd user
+
+DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron"
+HOMEPAGE="https://github.com/cronie-crond/cronie"
+SRC_URI="https://github.com/cronie-crond/cronie/archive/${P}.tar.gz"
+
+LICENSE="ISC BSD BSD-2 GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+IUSE="+anacron +inotify pam selinux"
+
+DEPEND="
+       pam? ( sys-libs/pam )
+       anacron? ( !sys-process/anacron
+               elibc_musl? ( sys-libs/obstack-standalone )
+       )
+"
+RDEPEND="${DEPEND}
+       sys-apps/debianutils
+"
+
+#cronie supports /etc/crontab
+CRON_SYSTEM_CRONTAB="yes"
+
+S="${WORKDIR}/${PN}-${P}"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-1.5.3-systemd.patch"
+)
+
+pkg_setup() {
+       enewgroup crontab
+}
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       local myeconfargs=(
+               $(use_with inotify)
+               $(use_with pam)
+               $(use_with selinux)
+               $(use_enable anacron)
+               --enable-syscrontab
+               --with-daemon_username=cron
+               --with-daemon_groupname=cron
+       )
+
+       if use anacron; then
+               use elibc_musl && append-cflags "-lobstack"
+       fi
+       SPOOL_DIR="/var/spool/cron/crontabs" \
+       ANACRON_SPOOL_DIR="/var/spool/anacron" \
+       econf "${myeconfargs[@]}"
+}
+
+src_install() {
+       default
+
+       docrondir -m 1730 -o root -g crontab
+       fowners root:crontab /usr/bin/crontab
+       fperms 2751 /usr/bin/crontab
+
+       newconfd "${S}"/crond.sysconfig ${PN}
+
+       insinto /etc
+       newins "${FILESDIR}/${PN}-crontab" crontab
+       newins "${FILESDIR}/${PN}-1.2-cron.deny" cron.deny
+
+       insinto /etc/cron.d
+       doins contrib/0hourly
+
+       newinitd "${FILESDIR}/${PN}-1.3-initd" ${PN}
+       newpamd "${FILESDIR}/${PN}-1.4.3-pamd" crond
+
+       systemd_newunit contrib/cronie.systemd cronie.service
+
+       if use anacron ; then
+               local anacrondir="/var/spool/anacron"
+               keepdir ${anacrondir}
+               fowners root:cron ${anacrondir}
+               fperms 0750 ${anacrondir}
+
+               insinto /etc
+               doins contrib/anacrontab
+
+               insinto /etc/cron.hourly
+               doins contrib/0anacron
+               fperms 0750 /etc/cron.hourly/0anacron
+       else
+               insinto /etc/cron.d
+               doins contrib/dailyjobs
+       fi
+
+       einstalldocs
+}
+
+pkg_postinst() {
+       cron_pkg_postinst
+
+       if [[ -n "${REPLACING_VERSIONS}" ]] ; then
+               ewarn "You should restart ${PN} daemon or else you might experience segfaults"
+               ewarn "or ${PN} not working reliably anymore."
+               einfo "(see https://bugs.gentoo.org/557406 for details.)"
+       fi
+}
index 275f06c603d4feb824b5d0b0179f965cbe6484f9..89ac6315c79553c8ab71002a4fda774010147508 100644 (file)
@@ -4,7 +4,7 @@ PATH=/sbin:/bin:/usr/sbin:/usr/bin
 MAILTO=root
 HOME=/
 
-# For details see man 4 crontabs
+# For details see man 5 crontab
 
 # Example of job definition:
 # .---------------- minute (0 - 59)