dev-util/scons: 3.0.5-r1 repair src_unpack() to fix Docbook tests
authorband-a-prend <torokhov-s-a@yandex.ru>
Fri, 7 Jun 2019 21:15:54 +0000 (00:15 +0300)
committerMichał Górny <mgorny@gentoo.org>
Sat, 15 Jun 2019 14:19:16 +0000 (16:19 +0200)
Now after the unpacking of scons github package (scons*.gh.tar.gz for test env)
no files are removed from "/src" directory to store files that
are necessary for some Docbook tests (*.xsl, *.xml, *.ent etc)
and for additional Scons env tests (some *.py files within 'engine' directory).

Signed-off-by: Sergey Torokhov <torokhov_s_a@mail.ru>
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-util/scons/scons-3.0.5-r1.ebuild

index e4524ab4aba5f4333ee38594f51f425147756866..5dba6c1f8dabdeabb91e76f972972501586666dc 100644 (file)
@@ -43,14 +43,11 @@ src_unpack() {
        # inside src/ subdirectory to make our life easier
        if use test; then
                unpack "${P}.gh.tar.gz"
-               rm -r "${P}/src" || die
        else
-               mkdir "${P}" || die
+               mkdir -p "${P}"/src || die
        fi
 
-       cd "${P}" || die
-       unpack "${P}.tar.gz"
-       mv "${P}" src || die
+       tar -C "${P}"/src --strip-components=1 -xzf "${DISTDIR}/${P}.tar.gz" || die
 }
 
 src_prepare() {