dev-python/guessit: Set DISTUTILS_USE_SETUPTOOLS
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 12:02:01 +0000 (13:02 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 12:02:01 +0000 (13:02 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/guessit/guessit-3.0.0.ebuild
dev-python/guessit/guessit-9999.ebuild

index aad2290ec2da278208800f33960deff02e628027..a1fbba8fd95478b59cd5a7047e47f8c50c4c07f6 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=6
 
+DISTUTILS_USE_SETUPTOOLS=rdepend
 PYTHON_COMPAT=( python3_6 )
 
 inherit distutils-r1
@@ -20,7 +21,6 @@ RDEPEND="
        >=dev-python/rebulk-0.9.0[${PYTHON_USEDEP}]
        dev-python/python-dateutil[${PYTHON_USEDEP}]
        dev-python/pyyaml[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
        dev-python/six[${PYTHON_USEDEP}]
 "
 
index a9cdfbda3f142fb99e5a06eb0819e52d5456b9ac..150c82479b9669b26edb85d394128fcaa1f0cbab 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=6
 
+DISTUTILS_USE_SETUPTOOLS=rdepend
 PYTHON_COMPAT=( python3_6 )
 
 inherit distutils-r1 git-r3
@@ -21,7 +22,6 @@ RDEPEND="
        >=dev-python/rebulk-0.9.0[${PYTHON_USEDEP}]
        dev-python/python-dateutil[${PYTHON_USEDEP}]
        dev-python/pyyaml[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
        dev-python/six[${PYTHON_USEDEP}]
 "