sci-libs/cantera: 2.4.0-r4 fix sci-libs/sundials-5.1.0 compatibility
authorSergey Torokhov <torokhov-s-a@yandex.ru>
Fri, 28 Feb 2020 22:49:41 +0000 (01:49 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 5 Mar 2020 11:54:37 +0000 (13:54 +0200)
As cantera-2.4.0-r3 was stabilized against sci-libs/sundials-3.2.0
therefore the changes allowing to build cantera agains sundials-5.1.0
don't affect the stability and avoid of dublicate patches
with trivial changes. Revision bump to -r4 saving stabilization.

The Sundials 5.1 has the same CVODES API as Sundials 4.0, 4.1, 5.0
so there is no any additional changes required to to build Cantera
against Sundials 5.1 except allowing in configuration check.

Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Closes: https://github.com/gentoo/gentoo/pull/14801
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
sci-libs/cantera/cantera-2.4.0-r4.ebuild [moved from sci-libs/cantera/cantera-2.4.0-r3.ebuild with 99% similarity]
sci-libs/cantera/files/cantera_2.4.0_sundials4.patch

similarity index 99%
rename from sci-libs/cantera/cantera-2.4.0-r3.ebuild
rename to sci-libs/cantera/cantera-2.4.0-r4.ebuild
index 29345e36058ca68f8c71c8a33a18b05fdac8d5c3..d3f8fb2e514bb17d90d8a211cdab575b6105b915 100644 (file)
@@ -32,7 +32,7 @@ RDEPEND="
                        dev-python/numpy[${PYTHON_MULTI_USEDEP}]
                ')
        )
-       <sci-libs/sundials-5.1.0:0=
+       <sci-libs/sundials-5.2.0:0=
 "
 
 DEPEND="
index 0345a98e252778cd9b089c2306e7ffb036d0c2aa..8c44228019b89c8c9f417012223acddbf389e285 100644 (file)
@@ -47,7 +47,7 @@ diff -Nur old/SConstruct new/SConstruct
      # Ignore the minor version, e.g. 2.4.x -> 2.4
      env['sundials_version'] = '.'.join(sundials_version.split('.')[:2])
 -    if env['sundials_version'] not in ('2.4','2.5','2.6','2.7','3.0','3.1','3.2'):
-+    if env['sundials_version'] not in ('2.4','2.5','2.6','2.7','3.0','3.1','3.2','4.0','4.1','5.0'):
++    if env['sundials_version'] not in ('2.4','2.5','2.6','2.7','3.0','3.1','3.2','4.0','4.1','5.0','5.1'):
          print("""ERROR: Sundials version %r is not supported.""" % env['sundials_version'])
          sys.exit(1)
      print("""INFO: Using system installation of Sundials version %s.""" % sundials_version)