dev-ros/unique_id: eapi7
authorAlexis Ballier <aballier@gentoo.org>
Mon, 18 May 2020 17:09:05 +0000 (19:09 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 18 May 2020 17:30:57 +0000 (19:30 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/unique_id/unique_id-1.0.6.ebuild
dev-ros/unique_id/unique_id-9999.ebuild

index 612f302dfc98dd6ad4eda551e1a25a82128ff278..7ff69d0fac632c45cdce343b3a7445c0c77e6109 100644 (file)
@@ -1,11 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 ROS_REPO_URI="https://github.com/ros-geographic-info/unique_identifier"
 VER_PREFIX=unique_identifier-
 KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
 ROS_SUBDIR=${PN}
 
 inherit ros-catkin
@@ -16,9 +15,10 @@ SLOT="0"
 IUSE=""
 
 RDEPEND="
-       dev-ros/uuid_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
        dev-ros/rospy[${PYTHON_USEDEP}]
        dev-ros/roscpp
 "
 DEPEND="${RDEPEND}
+       dev-ros/uuid_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
        test? ( dev-cpp/gtest dev-python/nose[${PYTHON_USEDEP}] )"
index c67faa3ad095681258b199e289ca5695d7aec4f6..7ff69d0fac632c45cdce343b3a7445c0c77e6109 100644 (file)
@@ -1,11 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 ROS_REPO_URI="https://github.com/ros-geographic-info/unique_identifier"
 VER_PREFIX=unique_identifier-
 KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
 ROS_SUBDIR=${PN}
 
 inherit ros-catkin
@@ -16,9 +15,10 @@ SLOT="0"
 IUSE=""
 
 RDEPEND="
-       dev-ros/uuid_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
        dev-ros/rospy[${PYTHON_USEDEP}]
        dev-ros/roscpp
 "
 DEPEND="${RDEPEND}
+       dev-ros/uuid_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
        test? ( dev-cpp/gtest dev-python/nose[${PYTHON_USEDEP}] )"