app-office/impressive: bump to 0.12.0
authorAndrey Grozin <grozin@gentoo.org>
Mon, 5 Feb 2018 07:03:44 +0000 (14:03 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Mon, 5 Feb 2018 07:03:44 +0000 (14:03 +0700)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

app-office/impressive/Manifest
app-office/impressive/impressive-0.12.0.ebuild [new file with mode: 0644]

index 71903474d050461f7730957d2140f04bedcc0a2d..ca8bf9e9161b20a638f45490fcbffd850cd08fe9 100644 (file)
@@ -1 +1,2 @@
 DIST Impressive-0.11.2.tar.gz 198391 BLAKE2B e0157a910b61c7dbe0796193b3d18f533210de50568d835e5204a848a5ac4978ab228b633d5137fb068af09a88d0c50fc2dbbb02b9b0d1a32a99f9de220ac1de SHA512 cabb52612f65ddadfb080e3db6417680a1aa9724fe45d8b78a1206b6508a8b60c5e5a7c218ff0f90e62adcd498aabe625837164fc547604dfd7aba425db87dd6
+DIST Impressive-0.12.0.tar.gz 209514 BLAKE2B aef0c793c85c680c65399cfcef56488c558ec49a8246d55bacc05a2e1fa0de51d548ddcf67788d36a4de91d62495a623269976345f99d63d25f3ae8bc9efdbd8 SHA512 3425d9d53c8c3ff6d5de0a3466bbf5c94f257390b4929ba12547ba930099de67db4f4d77d4ef4e3e10f8f723478569a74042553f64cf95e236931c7aabb70f0a
diff --git a/app-office/impressive/impressive-0.12.0.ebuild b/app-office/impressive/impressive-0.12.0.ebuild
new file mode 100644 (file)
index 0000000..6f865b6
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-r1
+
+MY_PN="Impressive"
+
+DESCRIPTION="Stylish way of giving presentations with Python"
+HOMEPAGE="http://impressive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}/${PV%b}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}
+       dev-python/pygame[${PYTHON_USEDEP}]
+       dev-python/pillow[${PYTHON_USEDEP}]
+       x11-apps/xrandr
+       app-text/mupdf
+       || ( media-fonts/dejavu media-fonts/corefonts )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=(
+       changelog.txt
+       demo.pdf
+)
+HTML_DOCS=(
+       impressive.html
+)
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+       default
+       python_foreach_impl python_doscript ${PN}.py
+       doman impressive.1
+}
+
+pkg_postinst() {
+       elog "The experience with ${PN} can be enhanced by folowing packages:"
+       optfeature "starting web or e-mail hyperlinks from PDF documents" x11-misc/xdg-utils
+       optfeature "sound and video playback" media-video/ffmpeg
+       optfeature "sound and video playback" media-video/mplayer
+       optfeature "sound and video playback" media-video/mplayer2
+       optfeature "extraction of PDF page titles" app-text/pdftk
+}