app-pda/usbmuxd: restore v1.0.8_p20140530
authorThomas Deutschmann <whissi@gentoo.org>
Wed, 18 Sep 2019 21:19:30 +0000 (23:19 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Wed, 18 Sep 2019 21:28:36 +0000 (23:28 +0200)
Fixes commit a82cb3bfaffb2442b26630a3bf6debfba8a7ce04 which deleted
last stable version.

Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
app-pda/usbmuxd/Manifest
app-pda/usbmuxd/usbmuxd-1.0.8_p20140530.ebuild [new file with mode: 0644]

index 7e34f3e1521c2691be06500caff8db9337e6aed4..c0da65d89c6e32e17de4b1ab1266921ce3a154aa 100644 (file)
@@ -1 +1,2 @@
+DIST usbmuxd-1.0.8_p20140530.tar.xz 46988 BLAKE2B 8efedee3231b134995316fc295fffd975271aa9d630aa6e3d96ccda472634422299aadb92acda09b6802cdcf9e99af0c165dcbed153d0a5027ffcc8f26126cdc SHA512 200c9bd208ef9e8d5e0a9b2779ff260efe6319333ce27c93a0686ba924e6cfaa1a003072c3eabbe46d495a66bc47c3cd6e82482653fde5e1a7ae0edd9b838fac
 DIST usbmuxd-1.1.0.tar.bz2 321897 BLAKE2B 3ca5d1da222e457ac01f3e87fb7573c6405e51fd5d270a2b3dab7601118f21be22232d5100b4d027273fc837e6a57f7a7d17d2c41ae59d7c5aa41f76bef5a03d SHA512 66aa0c40e912bf596b819098b87d88e9cf30b2e6352e607eeb778bd4f23bf9bb123fb6a6ecca2d4e4be3171e35d66200d632d2c9c80b1f2462bb45be8aa6912d
diff --git a/app-pda/usbmuxd/usbmuxd-1.0.8_p20140530.ebuild b/app-pda/usbmuxd/usbmuxd-1.0.8_p20140530.ebuild
new file mode 100644 (file)
index 0000000..17dd00c
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils udev user
+
+DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
+HOMEPAGE="http://www.libimobiledevice.org/"
+#SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
+SRC_URI="https://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+# src/utils.h is LGPL-2.1+, rest is found in COPYING*
+LICENSE="GPL-2 GPL-3 LGPL-2.1+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND="
+       acct-group/plugdev
+       >=app-pda/libimobiledevice-1.1.6
+       >=app-pda/libplist-1.11
+       virtual/libusb:1"
+DEPEND="${RDEPEND}
+       virtual/os-headers
+       virtual/pkgconfig"
+
+pkg_setup() {
+       enewuser usbmux -1 -1 -1 "usb,plugdev"
+}
+
+src_install() {
+       autotools-utils_src_install udevrulesdir="$(get_udevdir)"/rules.d
+}