dev-vcs/git: fix git-subtree.1 build failure
authorRobin H. Johnson <robbat2@gentoo.org>
Tue, 11 Jun 2019 15:25:59 +0000 (08:25 -0700)
committerRobin H. Johnson <robbat2@gentoo.org>
Tue, 11 Jun 2019 15:35:10 +0000 (08:35 -0700)
Partial revert of commit 56312573763e794982d7a7284e7e7d1a8a9f8eaa
Some of the manpages require the full documentation stack.

Documentation build is gated behind USE=doc due to the dependencies, so
move the manpage behind the conditional as well. As a future action, ask
upstream to include git-subtree.1 with the rest of the prebuilt
Documentation.

Fixes: https://bugs.gentoo.org/687848
See-Also: https://bugs.gentoo.org/517794
Package-Manager: Portage-2.3.67, Repoman-2.3.12
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
dev-vcs/git/git-2.22.0.ebuild
dev-vcs/git/git-9999-r1.ebuild
dev-vcs/git/git-9999-r2.ebuild
dev-vcs/git/git-9999-r3.ebuild
dev-vcs/git/git-9999.ebuild

index 64663fba9b7803eb1c7f0363a6ba42774a71eec8..42969a491fbfbd6c33d60e8cf563a269fa74c8d1 100644 (file)
@@ -384,8 +384,9 @@ src_compile() {
        fi
 
        pushd contrib/subtree &>/dev/null || die
-       git_emake git-subtree{,.1}
-       use doc && git_emake git-subtree.html
+       git_emake git-subtree
+       # git-subtree.1 requires the full USE=doc dependency stack
+       use doc && git_emake git-subtree.html git-subtree.1
        popd &>/dev/null || die
 
        pushd contrib/diff-highlight &>/dev/null || die
@@ -451,9 +452,10 @@ src_install() {
 
        # git-subtree
        pushd contrib/subtree &>/dev/null || die
-       git_emake install install-man || die "Failed to emake install install-man git-subtree"
+       git_emake install || die "Failed to emake install for git-subtree"
        if use doc ; then
-               git_emake install-html || die "Failed to emake install-html git-subtree"
+               # Do not move git subtree install-man outside USE=doc!
+               git_emake install-man install-html || die "Failed to emake install-html install-man for git-subtree"
        fi
        newdoc README README.git-subtree
        dodoc git-subtree.txt
index 64663fba9b7803eb1c7f0363a6ba42774a71eec8..42969a491fbfbd6c33d60e8cf563a269fa74c8d1 100644 (file)
@@ -384,8 +384,9 @@ src_compile() {
        fi
 
        pushd contrib/subtree &>/dev/null || die
-       git_emake git-subtree{,.1}
-       use doc && git_emake git-subtree.html
+       git_emake git-subtree
+       # git-subtree.1 requires the full USE=doc dependency stack
+       use doc && git_emake git-subtree.html git-subtree.1
        popd &>/dev/null || die
 
        pushd contrib/diff-highlight &>/dev/null || die
@@ -451,9 +452,10 @@ src_install() {
 
        # git-subtree
        pushd contrib/subtree &>/dev/null || die
-       git_emake install install-man || die "Failed to emake install install-man git-subtree"
+       git_emake install || die "Failed to emake install for git-subtree"
        if use doc ; then
-               git_emake install-html || die "Failed to emake install-html git-subtree"
+               # Do not move git subtree install-man outside USE=doc!
+               git_emake install-man install-html || die "Failed to emake install-html install-man for git-subtree"
        fi
        newdoc README README.git-subtree
        dodoc git-subtree.txt
index 64663fba9b7803eb1c7f0363a6ba42774a71eec8..42969a491fbfbd6c33d60e8cf563a269fa74c8d1 100644 (file)
@@ -384,8 +384,9 @@ src_compile() {
        fi
 
        pushd contrib/subtree &>/dev/null || die
-       git_emake git-subtree{,.1}
-       use doc && git_emake git-subtree.html
+       git_emake git-subtree
+       # git-subtree.1 requires the full USE=doc dependency stack
+       use doc && git_emake git-subtree.html git-subtree.1
        popd &>/dev/null || die
 
        pushd contrib/diff-highlight &>/dev/null || die
@@ -451,9 +452,10 @@ src_install() {
 
        # git-subtree
        pushd contrib/subtree &>/dev/null || die
-       git_emake install install-man || die "Failed to emake install install-man git-subtree"
+       git_emake install || die "Failed to emake install for git-subtree"
        if use doc ; then
-               git_emake install-html || die "Failed to emake install-html git-subtree"
+               # Do not move git subtree install-man outside USE=doc!
+               git_emake install-man install-html || die "Failed to emake install-html install-man for git-subtree"
        fi
        newdoc README README.git-subtree
        dodoc git-subtree.txt
index 64663fba9b7803eb1c7f0363a6ba42774a71eec8..42969a491fbfbd6c33d60e8cf563a269fa74c8d1 100644 (file)
@@ -384,8 +384,9 @@ src_compile() {
        fi
 
        pushd contrib/subtree &>/dev/null || die
-       git_emake git-subtree{,.1}
-       use doc && git_emake git-subtree.html
+       git_emake git-subtree
+       # git-subtree.1 requires the full USE=doc dependency stack
+       use doc && git_emake git-subtree.html git-subtree.1
        popd &>/dev/null || die
 
        pushd contrib/diff-highlight &>/dev/null || die
@@ -451,9 +452,10 @@ src_install() {
 
        # git-subtree
        pushd contrib/subtree &>/dev/null || die
-       git_emake install install-man || die "Failed to emake install install-man git-subtree"
+       git_emake install || die "Failed to emake install for git-subtree"
        if use doc ; then
-               git_emake install-html || die "Failed to emake install-html git-subtree"
+               # Do not move git subtree install-man outside USE=doc!
+               git_emake install-man install-html || die "Failed to emake install-html install-man for git-subtree"
        fi
        newdoc README README.git-subtree
        dodoc git-subtree.txt
index 9a03288ee8b7e9619ee769eb0475a06a2673c152..bf2df79b8abcea86ae7eca6c0d9263af4846ca01 100644 (file)
@@ -384,8 +384,9 @@ src_compile() {
        fi
 
        pushd contrib/subtree &>/dev/null || die
-       git_emake git-subtree{,.1}
-       use doc && git_emake git-subtree.html
+       git_emake git-subtree
+       # git-subtree.1 requires the full USE=doc dependency stack
+       use doc && git_emake git-subtree.html git-subtree.1
        popd &>/dev/null || die
 
        pushd contrib/diff-highlight &>/dev/null || die
@@ -451,9 +452,10 @@ src_install() {
 
        # git-subtree
        pushd contrib/subtree &>/dev/null || die
-       git_emake install install-man || die "Failed to emake install install-man git-subtree"
+       git_emake install || die "Failed to emake install for git-subtree"
        if use doc ; then
-               git_emake install-html || die "Failed to emake install-html git-subtree"
+               # Do not move git subtree install-man outside USE=doc!
+               git_emake install-man install-html || die "Failed to emake install-html install-man for git-subtree"
        fi
        newdoc README README.git-subtree
        dodoc git-subtree.txt