dev-python/ipyparallel: Version bump to 6.0.2
authorMarius Brehler <marbre@linux.sungazer.de>
Thu, 23 Feb 2017 10:49:19 +0000 (11:49 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 25 Feb 2017 14:18:20 +0000 (15:18 +0100)
Package-Manager: portage-2.3.3
Closes: https://github.com/gentoo/gentoo/pull/4060

dev-python/ipyparallel/Manifest
dev-python/ipyparallel/ipyparallel-6.0.2.ebuild [new file with mode: 0644]

index 8609a6fa06a465e181317296e3a466153cc1973a..73419cad8090243ba66f815c306a818fca8399af 100644 (file)
@@ -2,3 +2,4 @@ DIST ipyparallel-4.1.0.tar.gz 2271608 SHA256 c943f6b3bbabb9332336d15474969e2a7a7
 DIST ipyparallel-5.0.1.tar.gz 2350472 SHA256 48e319c16995a697c82e72dc4e5cb977be45cb0f0cdcfc482d5e8019ea6afeb2 SHA512 b7fa4f2ec5375398a533c92f07e2ab09180e537366c36ff5a7f3245d63072006ebcffc19dda28d08d5cc2e8a9044bf9101c7eeccf2857ed4a78ddd859ce23a2c WHIRLPOOL 350f67f7f341fe83bd21fb5f84714c43a426fa0d2234a532e781d0b0e9a977e2ee455184da995f5a3fbbf8e260d776dd9ac2607ac86041b5abecf41aeb9a8a9b
 DIST ipyparallel-5.1.1.tar.gz 2360986 SHA256 c46cd3bad50bbe12106257241d671ce6edb3faca2ced54ed001b8f1d579720f0 SHA512 66edfafeb6ca99b04ad08a61bbe7cbcfd9ba2689d16d19c476685d73f44ec40a4f2cde75e8394dbdc3b9e4da333afdfff8960bc9f37503aa4b28af90c63878db WHIRLPOOL eebf9c71b67c9ce129e125ca3ed7fb81f38ffb604805b861cc3239e113da52c1fb939fbf400d6c0cc7cfa29330ed60730a36447f7e74c45d788b33e6f1ac60ed
 DIST ipyparallel-5.2.0.tar.gz 2362590 SHA256 d99e760f1a136b1c402755a4ab51a8d7cb87c892cccadf641948a5e886c8a455 SHA512 1a3a4be28847ad11d43d96192ded62506380374b96a14cc9a6d6e945ac9592da7543fb5f9626a112068e548ed27f3291894a3cef544c65476c22b397458f60f3 WHIRLPOOL 29a77df915dfb487adabfb89ea96ee66253c14c7968699826f5be01073b43c753a2985bd940e09a708c92b4e9945b16d855b65a568523b1a75688a4aca022bca
+DIST ipyparallel-6.0.2.tar.gz 2366627 SHA256 7eea4780266252fcc987b220a302d589fbb4d6b0569bd131115a20b31891103d SHA512 2dab781eac81bb3c2d4eedff9689448ed8d4317b47a1e8110a0b16147f986428f6fefe13acd12ee8604ec7775aee46a5f62c7d6a676bda7f8d3d39d95d90f28d WHIRLPOOL e6f5047fbf153b587cb7b27924485648b6423f91ebee1541d961b8f1fd8179a18c08986652ff7f55a66168b276b1e7266c787b35bea950d50c8c761512fba867
diff --git a/dev-python/ipyparallel/ipyparallel-6.0.2.ebuild b/dev-python/ipyparallel/ipyparallel-6.0.2.ebuild
new file mode 100644 (file)
index 0000000..9b0dad4
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Interactive Parallel Computing with IPython"
+HOMEPAGE="http://ipython.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+       dev-python/ipython_genutils[${PYTHON_USEDEP}]
+       dev-python/decorator[${PYTHON_USEDEP}]
+       dev-python/python-dateutil[${PYTHON_USEDEP}]
+       >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+       dev-python/ipykernel[${PYTHON_USEDEP}]
+       !<dev-python/ipython-4.0.0[smp]
+       >=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
+       dev-python/notebook[${PYTHON_USEDEP}]
+       dev-python/jupyter_client[${PYTHON_USEDEP}]
+       www-servers/tornado[${PYTHON_USEDEP}]
+       "
+DEPEND="${RDEPEND}
+       $(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' 'python2*')
+       >=dev-python/setuptools-18.5[${PYTHON_USEDEP}]
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+       test? (
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/testpath[${PYTHON_USEDEP}]
+       )
+       "
+
+python_prepare_all() {
+       # Prevent un-needed download during build
+       if use doc; then
+               sed -e "/^    'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+       fi
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       if use doc; then
+               emake -C docs html
+               HTML_DOCS=( docs/build/html/. )
+       fi
+}
+
+python_test() {
+       iptest --coverage xml ipyparallel.tests -- -vsx || die
+}