dev-python/virtualenv: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sun, 26 Jan 2020 17:25:44 +0000 (18:25 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 26 Jan 2020 17:45:30 +0000 (18:45 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/virtualenv/virtualenv-15.1.0.ebuild [deleted file]
dev-python/virtualenv/virtualenv-16.7.7.ebuild [deleted file]
dev-python/virtualenv/virtualenv-16.7.8.ebuild [deleted file]

diff --git a/dev-python/virtualenv/virtualenv-15.1.0.ebuild b/dev-python/virtualenv/virtualenv-15.1.0.ebuild
deleted file mode 100644 (file)
index 18c9ac8..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Virtual Python Environment builder"
-HOMEPAGE="
-       https://virtualenv.pypa.io/en/stable/
-       https://pypi.org/project/virtualenv/
-       https://github.com/pypa/virtualenv/
-"
-SRC_URI="https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
-       >=dev-python/setuptools-19.6.2[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? (
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-       )"
-
-DOCS=( docs/index.rst docs/changes.rst )
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-12.1.1-skip-broken-test.patch
-)
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       py.test -v -v || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/virtualenv/virtualenv-16.7.7.ebuild b/dev-python/virtualenv/virtualenv-16.7.7.ebuild
deleted file mode 100644 (file)
index 31e1e3c..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# pypy{,3} dropped until test deps are tested/updated
-PYTHON_COMPAT=( python{2_7,3_{6,7}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Virtual Python Environment builder"
-HOMEPAGE="
-       https://virtualenv.pypa.io/en/stable/
-       https://pypi.org/project/virtualenv/
-       https://github.com/pypa/virtualenv/
-"
-SRC_URI="https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND=">=dev-python/setuptools-19.6.2[${PYTHON_USEDEP}]
-       test? (
-               >=dev-python/pip-19.3.1-r1[${PYTHON_USEDEP}]
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pypiserver[${PYTHON_USEDEP}]
-               dev-python/pytest-localserver[${PYTHON_USEDEP}]
-               dev-python/pytest-timeout[${PYTHON_USEDEP}]
-               dev-python/pytest-xdist[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/six[${PYTHON_USEDEP}]
-               dev-python/wheel[${PYTHON_USEDEP}]
-       )"
-
-DOCS=( docs/index.rst docs/changes.rst )
-
-PATCHES=(
-       "${FILESDIR}/virtualenv-16.7.7-tests.patch"
-
-       # disable tests that need internet access
-       "${FILESDIR}/virtualenv-16.7.7-tests-internet.patch"
-)
-
-distutils_enable_sphinx docs \
-       dev-python/sphinx_rtd_theme \
-       dev-python/towncrier
-
-python_test() {
-       cp "${S}"/LICENSE.txt "${BUILD_DIR}"/lib || \
-               die "Could not copy LICENSE.txt with ${EPYTHON}"
-
-       pytest -vv tests || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/virtualenv/virtualenv-16.7.8.ebuild b/dev-python/virtualenv/virtualenv-16.7.8.ebuild
deleted file mode 100644 (file)
index 1028458..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# pypy{,3} dropped until test deps are tested/updated
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Virtual Python Environment builder"
-HOMEPAGE="
-       https://virtualenv.pypa.io/en/stable/
-       https://pypi.org/project/virtualenv/
-       https://github.com/pypa/virtualenv/
-"
-SRC_URI="https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND=">=dev-python/setuptools-19.6.2[${PYTHON_USEDEP}]
-       test? (
-               >=dev-python/pip-19.3.1-r1[${PYTHON_USEDEP}]
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pypiserver[${PYTHON_USEDEP}]
-               dev-python/pytest-localserver[${PYTHON_USEDEP}]
-               dev-python/pytest-timeout[${PYTHON_USEDEP}]
-               dev-python/pytest-xdist[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/six[${PYTHON_USEDEP}]
-               dev-python/wheel[${PYTHON_USEDEP}]
-       )"
-
-DOCS=( docs/index.rst docs/changes.rst )
-
-PATCHES=(
-       "${FILESDIR}/virtualenv-16.7.7-tests.patch"
-
-       # disable tests that need internet access
-       "${FILESDIR}/virtualenv-16.7.7-tests-internet.patch"
-
-       # test fixes for pypy
-       "${FILESDIR}/virtualenv-16.7.8-tests-pypy.patch"
-)
-
-distutils_enable_sphinx docs \
-       dev-python/sphinx_rtd_theme \
-       dev-python/towncrier
-
-python_test() {
-       cp "${S}"/LICENSE.txt "${BUILD_DIR}"/lib || \
-               die "Could not copy LICENSE.txt with ${EPYTHON}"
-
-       pytest -vv tests || die "Tests fail with ${EPYTHON}"
-}