dev-libs/confuse: Version bump.
authorJeroen Roovers <jer@gentoo.org>
Thu, 10 Aug 2017 12:45:08 +0000 (14:45 +0200)
committerJeroen Roovers <jer@gentoo.org>
Thu, 10 Aug 2017 12:46:00 +0000 (14:46 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.3

dev-libs/confuse/Manifest
dev-libs/confuse/confuse-3.2.ebuild [new file with mode: 0644]

index c353787e07a1d3c66dfdd657e4fa5c5158263c8f..1c6540060792188bafe4afcde1be76ea611b920c 100644 (file)
@@ -1,2 +1,3 @@
 DIST confuse-3.0.tar.xz 449144 SHA256 bb75174e02aa8b44fa1a872a47beeea1f5fe715ab669694c97803eb6127cc861 SHA512 12279045b772e94d2e29201ab1d7aef1ef8e698780a22d6a282d12f51ccd9a437e7817a4dd5e39bdfc8dae79700b72aa0783b4b983a935d751403d2cffd1161e WHIRLPOOL fe9f792b9f0858029393a811da93746fb91dc6cc3c99bfcc3a183d7bc0f3600818b96df8d169c63e64a59cb0f3857a86298f0bfd4053c8360bcd2b6bd1e71156
 DIST confuse-3.1.tar.xz 468248 SHA256 8171f31e0071d5e4460269fdcc8b4e748cf23b4bf6bbe672f718a136dd63ca66 SHA512 64d6b11ffd2a32108c9a6e72cab00e6a7fe792d4400e68299336e8c8cebf3c352c7a6209c18336e22aaa478b3dd3945c641c91f3af9753c8b2bf42a6be9901d8 WHIRLPOOL c0b614b46e575de3f4e72cd7efc2d15846b255a8a437051a709fc42ea382f2b47b08e411c808fbeb084b83c7d013c770e7de792c0f60c2cdc1924f9545cc87d2
+DIST confuse-3.2.tar.xz 470108 SHA256 a46abb8696026d314197b6a70ae1a1c296342a9a68aa69b1935709c1477a4e48 SHA512 4c81b52bca951ab46961ed91bf9e887f7940dedfb69eaf2f6905cb2d88275e635c80d2570797e4276b5cd970b805ab902da6cd6f89dc64216b0b02445c912acd WHIRLPOOL 5edf49bb58215b5694b66679c6638a16e0f9b3080f4b89b660d43329a622b9771f1403424a7eac1fccc6eaf7ffd80b1994629a09ebab3e29abda31bb902ba935
diff --git a/dev-libs/confuse/confuse-3.2.ebuild b/dev-libs/confuse/confuse-3.2.ebuild
new file mode 100644 (file)
index 0000000..163dcf7
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="a configuration file parser library"
+HOMEPAGE="http://www.nongnu.org/confuse/"
+SRC_URI="https://github.com/martinh/libconfuse/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0/1.1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+
+IUSE="nls static-libs"
+
+DEPEND="sys-devel/flex
+       sys-devel/libtool
+       virtual/pkgconfig
+       nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl[${MULTILIB_USEDEP}] )"
+
+DOCS=( AUTHORS )
+
+src_prepare() {
+       eapply_user
+       multilib_copy_sources
+}
+
+multilib_src_configure() {
+       # examples are normally compiled but not installed. They
+       # fail during a mingw crosscompile.
+       local ECONF_SOURCE=${BUILD_DIR}
+       econf \
+               --enable-shared \
+               --disable-examples \
+               $(use_enable nls) \
+               $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+       prune_libtool_files
+
+       doman doc/man/man3/*.3
+       dodoc -r doc/html
+
+       docinto examples
+       dodoc examples/*.{c,conf}
+}