sys-block/seekwatcher: switch to single python implementation
authorSergei Trofimovich <slyfox@gentoo.org>
Mon, 20 Apr 2020 06:53:11 +0000 (07:53 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Mon, 20 Apr 2020 06:59:01 +0000 (07:59 +0100)
Will alllow setting multiple supported PYTHON_COMPAT
implementations to choose from.

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-block/seekwatcher/seekwatcher-0.13.ebuild

index d079d0df137fa81a6bdf4427d3520c93fbbca9ba..065f00204e259cbc15b2b61553b2623802759a7d 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=7
 
+DISTUTILS_SINGLE_IMPL=1
 DISTUTILS_USE_SETUPTOOLS=no
 PYTHON_COMPAT=( python3_6 )
 
@@ -17,10 +18,16 @@ SLOT="0"
 KEYWORDS="amd64 x86"
 IUSE=""
 
-DEPEND="dev-python/cython"
+BDEPEND="$(python_gen_cond_dep '
+               dev-python/cython[${PYTHON_MULTI_USEDEP}]
+       ')
+"
+
 RDEPEND="
-       dev-python/matplotlib[${PYTHON_USEDEP}]
-       dev-python/numpy[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               dev-python/matplotlib[${PYTHON_MULTI_USEDEP}]
+               dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+       ')
        sys-block/blktrace
 "