x11-wm/mutter: bump to 3.34.5
authorMart Raudsepp <leio@gentoo.org>
Sat, 4 Apr 2020 10:23:35 +0000 (13:23 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sat, 4 Apr 2020 12:06:49 +0000 (15:06 +0300)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
x11-wm/mutter/Manifest
x11-wm/mutter/mutter-3.34.5.ebuild [new file with mode: 0644]

index 7a35e41d99093773c195bb421d15909620f28eb8..278937a2b4a37190abab44a010ffc26f1246040a 100644 (file)
@@ -4,3 +4,4 @@ DIST mutter-3.32.2-patchset.tar.xz 26872 BLAKE2B 026c87cc3859624bcfd273694a8a346
 DIST mutter-3.32.2.tar.xz 2797664 BLAKE2B 8b69436778d9c3e10b0373c83e1f306cb2718e49ad1f351f2e3a1ef92caeb1eb7a391be07c60578cfb2601eea5dc3949b1d8305e9f079b2b00d43ff305409f00 SHA512 e4494d028ae71441fbdc584bd8acd9c2559d52ac72402bad9a7cb43f4f519487d11df6453172fd27a9df7f2cade020d6317931613bd0be343c66170e6cda0269
 DIST mutter-3.34.4-patchset.tar.xz 7216 BLAKE2B 6a9d503a8da80a9255649150c1256ea0d1459b11c0803728553f6699f0bb54b56161a411e9dec3725e5cd4230531c90b0160ef702083285443849c9ec4ca8278 SHA512 b592a6ded20c61c15fe8dc5a69fb73e81143975632237a32329bbf40239bdc2c392aef4676cd8800f7ad39eb16e8f159b0cec87c8bd035302db0a8001ddeda2e
 DIST mutter-3.34.4.tar.xz 2791624 BLAKE2B cd7ea49333dc50574f993f15638504eac0d0a6f1e85f34a617accbabcec71f02244ce6cd292c968def302652707e21692d94dcccb01d59b3661220c90cefd802 SHA512 6cae8473071d9ab105a3635cee314157a268894fc3b18e53857e097223a9c2677e1cd51b10b501a3b85f74c83470c2ce87986972218f9833c9f6ad31b1910f6a
+DIST mutter-3.34.5.tar.xz 2804640 BLAKE2B b73a34f4e064b74b321b7ac54749170663c10874a82c0e4f6b20b1f9d97662af0ba188e5ac13a187117765b8aee820fc7367dfbeecc26002942151e77433012c SHA512 4199cf66e6551ebf80b9d2217e3164b1de30b055c58a64bc2d88961aad3a35c137174f6aea96f0250fa3efb2bf4676aa409fefb1a9237bbc7acf438aeed2e78a
diff --git a/x11-wm/mutter/mutter-3.34.5.ebuild b/x11-wm/mutter/mutter-3.34.5.ebuild
new file mode 100644 (file)
index 0000000..4703c77
--- /dev/null
@@ -0,0 +1,145 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson virtualx xdg
+
+DESCRIPTION="GNOME 3 compositing window manager based on Clutter"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/mutter/"
+
+LICENSE="GPL-2+"
+SLOT="0/5" # 0/libmutter_api_version - ONLY gnome-shell (or anything using mutter-clutter-<api_version>.pc) should use the subslot
+
+IUSE="elogind input_devices_wacom +introspection screencast +sysprof systemd test udev wayland"
+# native backend requires gles3 for hybrid graphics blitting support, udev and a logind provider
+REQUIRED_USE="
+       wayland? ( ^^ ( elogind systemd ) udev )
+       test? ( wayland )"
+RESTRICT="!test? ( test )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# gnome-settings-daemon is build checked, but used at runtime only for org.gnome.settings-daemon.peripherals.keyboard gschema
+# xorg-server is needed at build and runtime with USE=wayland for Xwayland
+# v3.32.2 has many excessive or unused *_req variables declared, thus currently the dep order ignores those and goes via dependency() call order
+DEPEND="
+       x11-libs/libX11
+       >=x11-libs/gtk+-3.19.8:3[X,introspection?]
+       x11-libs/gdk-pixbuf:2
+       >=x11-libs/pango-1.30[introspection?]
+       >=dev-libs/fribidi-1.0.0
+       >=x11-libs/cairo-1.14[X]
+       >=gnome-base/gsettings-desktop-schemas-3.33.0[introspection?]
+       >=dev-libs/glib-2.61.1:2
+       gnome-base/gnome-settings-daemon
+       >=dev-libs/json-glib-0.12.0[introspection?]
+       gnome-base/gnome-desktop:3=
+       >=x11-libs/libXcomposite-0.4
+       x11-libs/libXcursor
+       x11-libs/libXdamage
+       x11-libs/libXext
+       >=x11-libs/libXfixes-3
+       >=x11-libs/libXi-1.7.4
+       x11-libs/libXtst
+       x11-libs/libxkbfile
+       x11-misc/xkeyboard-config
+       >=x11-libs/libxkbcommon-0.4.3[X]
+       x11-libs/libXrender
+       >=x11-libs/libXrandr-1.5.0
+       x11-libs/libxcb
+       x11-libs/libXinerama
+       x11-libs/libXau
+       x11-libs/libICE
+       >=dev-libs/atk-2.5.3[introspection?]
+       >=media-libs/libcanberra-0.26
+       media-libs/mesa[X(+),egl]
+       wayland? (
+               >=dev-libs/wayland-protocols-1.18
+               >=dev-libs/wayland-1.13.0
+               x11-libs/libdrm:=
+               >=media-libs/mesa-10.3[egl,gbm,wayland,gles2]
+               >=dev-libs/libinput-1.4
+               systemd? ( sys-apps/systemd )
+               elogind? ( sys-auth/elogind )
+               x11-base/xorg-server[wayland]
+       )
+       udev? ( >=dev-libs/libgudev-232:=
+               >=virtual/libudev-232-r1:= )
+       x11-libs/libSM
+       input_devices_wacom? ( >=dev-libs/libwacom-0.13 )
+       >=x11-libs/startup-notification-0.7
+       screencast? ( >=media-video/pipewire-0.2.2:0/0.2 )
+       introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+RDEPEND="${DEPEND}
+       gnome-extra/zenity
+"
+DEPEND="${DEPEND}
+       x11-base/xorg-proto
+       sysprof? ( >=dev-util/sysprof-capture-3.34.1-r1:3 )
+"
+# wayland bdepend for wayland-scanner, xorg-server for cvt utility
+BDEPEND="
+       dev-libs/wayland
+       >=dev-util/meson-0.50.0
+       dev-util/gdbus-codegen
+       dev-util/glib-utils
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+       test? ( app-text/docbook-xml-dtd:4.5 )
+       wayland? ( >=sys-kernel/linux-headers-4.4
+               x11-base/xorg-server )
+"
+
+PATCHES=(
+       "${FILESDIR}"/3.32-eglmesaext-include.patch
+)
+
+src_configure() {
+       # TODO: Replicate debug vs release meson build type behaviour under our buildtype=plain
+       local emesonargs=(
+               -Dopengl=true
+               #opengl_libname
+               #gles2_libname
+               $(meson_use wayland gles2)
+               -Degl=true
+               -Dglx=true
+               $(meson_use wayland)
+               $(meson_use wayland native_backend)
+               $(meson_use screencast remote_desktop)
+               -Degl_device=false # This should be dependent on wayland,video_drivers_nvidia, once eglstream support is there
+               -Dwayland_eglstream=false # requires packages egl-wayland for wayland-eglstream-protocols.pc
+               $(meson_use udev)
+               $(meson_use input_devices_wacom libwacom)
+               -Dpango_ft2=true
+               -Dstartup_notification=true
+               -Dsm=true
+               $(meson_use introspection)
+               $(meson_use test cogl_tests)
+               $(meson_use wayland core_tests) # core tests require wayland; overall -Dtests option is honored on top, so no extra conditional needed
+               $(meson_use test clutter_tests)
+               $(meson_use test tests)
+               $(meson_use sysprof profiler)
+               -Dinstalled_tests=false
+               #verbose # Let upstream choose default for verbose mode
+               #xwayland_path
+               # TODO: relies on default settings, but in Gentoo we might have some more packages we want to give Xgrab access (mostly virtual managers and remote desktops)
+               #xwayland_grab_default_access_rules
+       )
+       meson_src_configure
+}
+
+src_test() {
+       glib-compile-schemas "${BUILD_DIR}"/data
+       GSETTINGS_SCHEMA_DIR="${BUILD_DIR}"/data virtx meson_src_test
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_schemas_update
+}