dev-python/jinja: Bump to 2.11.2
authorMichał Górny <mgorny@gentoo.org>
Tue, 14 Apr 2020 05:06:58 +0000 (07:06 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 14 Apr 2020 05:33:03 +0000 (07:33 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/jinja/Manifest
dev-python/jinja/jinja-2.11.2.ebuild [new file with mode: 0644]

index ca899e018f8367e3d291b3f2aeb2e8bbe7b55c67..162f85477e8642f2715b73a748151e694f5488b9 100644 (file)
@@ -1,2 +1,3 @@
 DIST jinja-2.11.1.tar.gz 258637 BLAKE2B 80826397ada553b2bd1452f72430589ddebbd55aecffe6c6d9161ddcb46d9caa35635abd0946e063efda856391843831d25a7de91250d0f066b12cbf8b4af988 SHA512 66d9b7923f4b78133489bc28525d83032d37d5409ac572c00ea1aa342b3291bf0505c1e9d62f7a553553e26f06885e3d5c71bdcd2b334064b610692681694d33
+DIST jinja-2.11.2.tar.gz 258055 BLAKE2B 5cf12d6c79e7e659b16318cb3dc483a276511192903469629ec497c10ba6cd023f5a834961ac74cbda556177aaac46f5045c5aaca3068dcef87017760895851c SHA512 453e0c94c57065ab78f997726256bd2a31bb79124a2ee17b632cb124a3ccefded33d81b35cac73497f095b1cd5d8cd4420d6932a637fd7c4cdb786f1753e49ac
 DIST jinja-2.8.1.tar.gz 397144 BLAKE2B 78e4903da05ab3e8961b6bb6047116941b4bbf59d08b8283582972590409f98b5dc1f468a988525d96c552000279fcd0a31dae3ac1e5226f609a8854c8f9ca0b SHA512 f4655f1a43c06f7651fbd5251d0538788a3a6a3ffb93d9a8c239711cf043082c43d34706b6d71a18679d957faa6590e7e0259ffb8f7cc5e3300749526417a987
diff --git a/dev-python/jinja/jinja-2.11.2.ebuild b/dev-python/jinja/jinja-2.11.2.ebuild
new file mode 100644 (file)
index 0000000..5ee872d
--- /dev/null
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A full-featured template engine for Python"
+HOMEPAGE="http://jinja.pocoo.org/ https://pypi.org/project/Jinja2/"
+# pypi tarball is missing tests
+SRC_URI="https://github.com/pallets/jinja/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="examples"
+
+RDEPEND="
+       dev-python/markupsafe[${PYTHON_USEDEP}]
+       !dev-python/jinja:compat"
+
+distutils_enable_sphinx docs \
+       dev-python/sphinx-issues \
+       dev-python/pallets-sphinx-themes
+distutils_enable_tests pytest
+
+# XXX: handle Babel better?
+
+src_prepare() {
+       # avoid unnecessary dep on extra sphinxcontrib modules
+       sed -i '/sphinxcontrib.log_cabinet/ d' docs/conf.py || die
+
+       distutils-r1_src_prepare
+}
+
+python_compile() {
+       distutils-r1_python_compile
+
+       if ! python_is_python3; then
+               rm "${BUILD_DIR}"/lib/jinja2/async*.py || die
+       fi
+}
+
+python_install() {
+       distutils-r1_python_install --skip-build
+}
+
+python_install_all() {
+       if use examples ; then
+               docinto examples
+               dodoc -r examples/.
+       fi
+
+       distutils-r1_python_install_all
+
+       insinto /usr/share/vim/vimfiles/syntax
+       doins ext/Vim/*
+}
+
+pkg_postinst() {
+       if ! has_version dev-python/Babel; then
+               elog "For i18n support, please emerge dev-python/Babel."
+       fi
+}