media-libs/mlt: Re-add python2_7 support
authorAndreas Sturmlechner <asturm@gentoo.org>
Tue, 16 Jul 2019 17:52:52 +0000 (19:52 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Tue, 16 Jul 2019 17:52:52 +0000 (19:52 +0200)
Thanks-to: ak <4nykey@gmail.com>
Closes: https://bugs.gentoo.org/689068
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-libs/mlt/mlt-6.16.0-r1.ebuild
media-libs/mlt/mlt-6.16.0-r2.ebuild

index 6161697e042f1251a0ecb8c2b3962f6e34ff8ea7..dee7260c926b7dda647a52ccf5f6285f658366bc 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
 # this ebuild currently only supports installing ruby bindings for a single ruby version
 # so USE_RUBY must contain only a single value (the latest stable) as the ebuild calls
 # /usr/bin/${USE_RUBY} directly
@@ -112,8 +112,12 @@ src_prepare() {
 
        sed -i -e "s/env ruby/${USE_RUBY}/" src/swig/ruby/* || die
 
-       # fix python3 include dir
-       sed -i -e 's/python{}.{}/python{}.{}m/' src/swig/python/build || die
+       # fix python include dir
+       if use python; then
+               python_export PYTHON_INCLUDEDIR
+               sed -e "/PYTHON_INCLUDE=/s:=.*:=${PYTHON_INCLUDEDIR}:" \
+                       -i src/swig/python/build || die
+       fi
 }
 
 src_configure() {
index 1605afaedcedd8b9ef833379bb6d8d16586e8997..31ed25573ff9e097c4de0448c81e1b59214b6a3a 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
 # this ebuild currently only supports installing ruby bindings for a single ruby version
 # so USE_RUBY must contain only a single value (the latest stable) as the ebuild calls
 # /usr/bin/${USE_RUBY} directly
@@ -112,8 +112,12 @@ src_prepare() {
 
        sed -i -e "s/env ruby/${USE_RUBY}/" src/swig/ruby/* || die
 
-       # fix python3 include dir
-       sed -i -e 's/python{}.{}/python{}.{}m/' src/swig/python/build || die
+       # fix python include dir
+       if use python; then
+               python_export PYTHON_INCLUDEDIR
+               sed -e "/PYTHON_INCLUDE=/s:=.*:=${PYTHON_INCLUDEDIR}:" \
+                       -i src/swig/python/build || die
+       fi
 }
 
 src_configure() {