dev-lang/julia: fix library installation path
authorMatthias Maier <tamiko@gentoo.org>
Sun, 1 Jul 2018 04:32:31 +0000 (23:32 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Sun, 1 Jul 2018 04:49:04 +0000 (23:49 -0500)
Closes: https://bugs.gentoo.org/655072
Package-Manager: Portage-2.3.41, Repoman-2.3.9

dev-lang/julia/files/julia-0.6.3-fix_build_system.patch [new file with mode: 0644]
dev-lang/julia/julia-0.6.3-r1.ebuild [moved from dev-lang/julia/julia-0.6.3.ebuild with 89% similarity]

diff --git a/dev-lang/julia/files/julia-0.6.3-fix_build_system.patch b/dev-lang/julia/files/julia-0.6.3-fix_build_system.patch
new file mode 100644 (file)
index 0000000..41e6467
--- /dev/null
@@ -0,0 +1,96 @@
+diff --git a/Make.inc b/Make.inc
+index 7f3a37c..3560d93 100644
+--- a/Make.inc
++++ b/Make.inc
+@@ -180,7 +180,7 @@ USE_GPL_LIBS ?= 1
+ # Directories where said libraries get installed to
+ prefix ?= $(BUILDROOT)/julia-$(JULIA_COMMIT)
+ bindir := $(prefix)/bin
+-libdir := $(prefix)/lib
++libdir := $(prefix)/GENTOOLIBDIR
+ libexecdir := $(prefix)/libexec
+ datarootdir := $(prefix)/share
+ docdir := $(datarootdir)/doc/julia
+@@ -400,7 +400,7 @@ ifneq ($(OS), WINNT)
+ JCXXFLAGS += -pedantic
+ endif
+ DEBUGFLAGS := -O0 -ggdb2 -DJL_DEBUG_BUILD -fstack-protector-all
+-SHIPFLAGS := -O3 -ggdb2 -falign-functions
++SHIPFLAGS := GENTOOCFLAGS
+ endif
+ ifeq ($(USECLANG),1)
+@@ -411,7 +411,7 @@ JCFLAGS := -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
+ JCPPFLAGS := -fasynchronous-unwind-tables
+ JCXXFLAGS := -pipe $(fPIC) -fno-rtti -pedantic
+ DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
+-SHIPFLAGS := -O3 -g
++SHIPFLAGS := GENTOOCFLAGS
+ ifeq ($(OS), Darwin)
+ ifeq ($(USE_LIBCPP), 1)
+ MACOSX_VERSION_MIN := 10.8
+@@ -440,7 +440,7 @@ JCFLAGS := -std=gnu11 -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
+ JCPPFLAGS :=
+ JCXXFLAGS := -pipe $(fPIC) -fno-rtti
+ DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
+-SHIPFLAGS := -O3 -g -falign-functions
++SHIPFLAGS := GENTOOCFLAGS
+ endif
+ ifeq ($(USECCACHE), 1)
+diff --git a/deps/tools/jldownload b/deps/tools/jldownload
+index ab4fd69..e2c2408 100755
+--- a/deps/tools/jldownload
++++ b/deps/tools/jldownload
+@@ -5,9 +5,9 @@
+ CACHE_HOST=https://cache.julialang.org
+-WGET=$(which wget 2>/dev/null)
+-CURL=$(which curl 2>/dev/null)
+-FETCH=$(which fetch 2>/dev/null)
++WGET=/bin/true
++CURL=/bin/true
++FETCH=/bin/true
+ TIMEOUT=15 # seconds
+ WGET_OPTS="--no-check-certificate --tries=1 --timeout=$TIMEOUT"
+diff --git a/doc/Makefile b/doc/Makefile
+index 743804d..e06dde0 100644
+--- a/doc/Makefile
++++ b/doc/Makefile
+@@ -25,7 +25,7 @@ deps: UnicodeData.txt
+       $(JLCHECKSUM) UnicodeData.txt
+ clean:
+-      -rm -rf _build/* deps/* docbuild.log UnicodeData.txt
++      @echo "Do not clean doc/_build/html. Just use it..."
+ cleanall: clean
+diff --git a/src/Makefile b/src/Makefile
+index 9fde74d..e01ab2e 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -85,20 +85,8 @@ PUBLIC_HEADER_TARGETS := $(addprefix $(build_includedir)/julia/,$(notdir $(PUBLI
+ # In LLVM < 3.4, --ldflags includes both options and libraries, so use it both before and after --libs
+ # In LLVM >= 3.4, --ldflags has only options, and --system-libs has the libraries.
+-ifneq ($(USE_LLVM_SHLIB),1)
+-LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) $(shell $(LLVM_CONFIG_HOST) --libs $(LLVM_LIBS)) $(shell $(LLVM_CONFIG_HOST) --ldflags) $(shell $(LLVM_CONFIG_HOST) --system-libs 2> /dev/null)
+-else
+-ifeq ($(LLVM_USE_CMAKE),1)
+-LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) -lLLVM
+-else
+-ifeq ($(OS),WINNT)
+-LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) -lLLVM-$(LLVM_VER_SHORT)
+-else
+-LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) -lLLVM-$(shell $(LLVM_CONFIG_HOST) --version)
+-endif # OS == WINNT
+-endif # LLVM_USE_CMAKE == 1
++LLVMLINK = $(call exec,$(LLVM_CONFIG) --ldflags) $(call exec,$(LLVM_CONFIG) --libs) $(call exec,$(LLVM_CONFIG) --ldflags) $(call exec,$(LLVM_CONFIG) --system-libs)
+ FLAGS += -DLLVM_SHLIB
+-endif # USE_LLVM_SHLIB == 1
+ COMMON_LIBS := -L$(build_shlibdir) -L$(build_libdir) $(LIBUV) $(LIBUTF8PROC) $(NO_WHOLE_ARCHIVE) $(LLVMLINK) $(OSLIBS)
+ DEBUG_LIBS := $(WHOLE_ARCHIVE) $(BUILDDIR)/flisp/libflisp-debug.a $(WHOLE_ARCHIVE) $(BUILDDIR)/support/libsupport-debug.a $(COMMON_LIBS)
similarity index 89%
rename from dev-lang/julia/julia-0.6.3.ebuild
rename to dev-lang/julia/julia-0.6.3-r1.ebuild
index ba814f621915935641a019b07c7f0784f9c120cb..163fa629a2089bfa750ec4ff7c506e4401dd840f 100644 (file)
@@ -54,7 +54,7 @@ DEPEND="${RDEPEND}
        virtual/pkgconfig"
 
 PATCHES=(
-       "${FILESDIR}"/${PN}-0.6.0-fix_build_system.patch
+       "${FILESDIR}"/${PN}-0.6.3-fix_build_system.patch
 )
 
 src_prepare() {
@@ -85,12 +85,8 @@ src_prepare() {
        liblapack="lib${liblapack#-l}"
 
        sed -i \
-               -e "s|\(JULIA_EXECUTABLE = \)\(\$(JULIAHOME)/julia\)|\1 LD_LIBRARY_PATH=\$(BUILD)/$(get_libdir) \2|" \
                -e "s|GENTOOCFLAGS|${CFLAGS}|g" \
-               -e "s|LIBDIR = lib|LIBDIR = $(get_libdir)|" \
-               -e "s|/usr/lib|${EPREFIX}/usr/$(get_libdir)|" \
-               -e "s|/usr/include|${EPREFIX}/usr/include|" \
-               -e "s|\$(BUILD)/lib|\$(BUILD)/$(get_libdir)|" \
+               -e "s|GENTOOLIBDIR|$(get_libdir)|" \
                -e "s|^JULIA_COMMIT = .*|JULIA_COMMIT = v${PV}|" \
                -e "s|-lblas|$($(tc-getPKG_CONFIG) --libs blas)|" \
                -e "s|= libblas|= ${libblas}|" \
@@ -187,8 +183,4 @@ src_install() {
        mv "${ED}"/usr/share/doc/julia/{examples,html} \
                "${ED}"/usr/share/doc/${PF} || die
        rmdir "${ED}"/usr/share/doc/julia || die
-       if [[ $(get_libdir) != lib ]]; then
-               mkdir -p "${ED}"/usr/$(get_libdir) || die
-               mv "${ED}"/usr/lib/julia "${ED}"/usr/$(get_libdir)/julia || die
-       fi
 }