app-emacs/uptimes: Bump version to 3.7.
authorUlrich Müller <ulm@gentoo.org>
Sat, 7 Sep 2019 08:16:15 +0000 (10:16 +0200)
committerUlrich Müller <ulm@gentoo.org>
Sat, 7 Sep 2019 09:04:24 +0000 (11:04 +0200)
Package-Manager: Portage-2.3.73, Repoman-2.3.17
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-emacs/uptimes/Manifest
app-emacs/uptimes/metadata.xml
app-emacs/uptimes/uptimes-3.7.ebuild [new file with mode: 0644]

index fc5ae50f32d3dcbd2831e7524879c9a8fa8df7be..ec4a13287bb0778d1629c0521978214acf3ce473 100644 (file)
@@ -1 +1,2 @@
 DIST uptimes-2.3.tar.bz2 3637 BLAKE2B 75517032993f8192c4985d6bb5793b90c828565495a4471845e3efb6fa939268c7b94751baa6b85f5462cfb2a944ea4f4904a75b950a071c0840bb21313bb751 SHA512 31a8e4da410c1c02e96b3aa910fb3afe99c924af0f8299465e1c1b4b22e925aeb427b1ad349df459f93d2efd8bbf66804186f26486957d9e8196eda1b50eb5ba
+DIST uptimes-3.7.tar.gz 3913 BLAKE2B 3148b17a8e61201027702891e0303870cddaace650770621bf7847cb86ba917c74aa5938f55fe2e6275180f9e66755f418dee47bc80b6fd7439276ff525ea9d8 SHA512 6e31cdacabc93a8f9d206d95eb4d16ad4a6b4a69f1032e93710693eebe8064446b19e4938eb342c8a66fac7e52e22da36b26bd3417216ab302c9c8e50dba27c3
index c918cdef959136ebef10a3a412d06b6cb9123412..bb9b255aed7d4e748274bb3471e6768733f50f3a 100644 (file)
@@ -5,5 +5,13 @@
   <email>gnu-emacs@gentoo.org</email>
   <name>Gentoo GNU Emacs project</name>
 </maintainer>
+<longdescription>
+  uptimes.el provides a simple system for tracking and displaying the
+  uptimes of your Emacs sessions. Simply loading uptimes.el from your
+  ~/.emacs file will start the tracking of any session.
+</longdescription>
 <stabilize-allarches/>
+<upstream>
+  <remote-id type="github">davep/uptimes.el</remote-id>
+</upstream>
 </pkgmetadata>
diff --git a/app-emacs/uptimes/uptimes-3.7.ebuild b/app-emacs/uptimes/uptimes-3.7.ebuild
new file mode 100644 (file)
index 0000000..224e426
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp readme.gentoo-r1
+
+MY_PN="${PN}.el"
+DESCRIPTION="Track and display emacs session uptimes"
+HOMEPAGE="http://www.davep.org/emacs/"
+SRC_URI="https://github.com/davep/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+SITEFILE="50${PN}-gentoo.el"
+DOC_CONTENTS="Uptimes is not enabled as a site default. Add the following
+       line to your ~/.emacs file to enable tracking of session uptimes:
+       \n(require 'uptimes)"