net-misc/autoupnp: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Sun, 10 Nov 2019 20:59:43 +0000 (21:59 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 10 Nov 2019 21:10:51 +0000 (22:10 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-misc/autoupnp/autoupnp-0.4.7.ebuild
net-misc/autoupnp/autoupnp-9999.ebuild

index 5026fdeabd88f0e5f6b27ff9b14769d4d6f76c56..c418eecc98a7f644e25604352806f056f348297b 100644 (file)
@@ -1,9 +1,7 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-
-inherit eutils
+EAPI=7
 
 DESCRIPTION="Automatic open port forwarder using UPnP"
 HOMEPAGE="https://github.com/mgorny/autoupnp/"
@@ -28,5 +26,5 @@ src_configure() {
 
 src_install() {
        default
-       prune_libtool_files --all
+       find "${D}" -name '*.la' -delete || die
 }
index 2cc6e7484420e7320c3b43fe72ea24ed0a91af8e..f7ea428391eaba5ac5d181efa98315397ce4013d 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 
-inherit autotools eutils git-r3
+inherit autotools git-r3
 
 DESCRIPTION="Automatic open port forwarder using UPnP"
 HOMEPAGE="https://github.com/mgorny/autoupnp/"
@@ -19,6 +19,7 @@ RDEPEND="net-libs/miniupnpc:0=
 DEPEND="${RDEPEND}"
 
 src_prepare() {
+       default
        eautoreconf
 }
 
@@ -32,5 +33,5 @@ src_configure() {
 
 src_install() {
        default
-       prune_libtool_files --all
+       find "${D}" -name '*.la' -delete || die
 }