dev-util/catkin: Bump to 0.7.5.
authorAlexis Ballier <aballier@gentoo.org>
Thu, 16 Feb 2017 04:20:20 +0000 (05:20 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 16 Feb 2017 04:31:43 +0000 (05:31 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-util/catkin/Manifest
dev-util/catkin/catkin-0.7.5.ebuild [new file with mode: 0644]

index 0491695b6d39623b702a3461913bfd15515e9c50..9f9d2edbbb7ba6941e65cf64c8219cad2c84502e 100644 (file)
@@ -1 +1,2 @@
 DIST catkin-0.7.4.tar.gz 201140 SHA256 e113577697cd58432111c187b3faaa0df365f7694fe81ff71f9d29b65d467e48 SHA512 89bd38e8fbe4eba481404295f83a77974a2af14a038d326b294029d84789356290480588d7824e4e9849a9974a8ca08be13115c459aa6e00a8e36ce861f46a83 WHIRLPOOL 66b738d02609d9cfe891f7e159ec8ff980acb18208b635d25e9c66895e85ebd6024082ff117d3c1e0a26ebe529d7079aea2f8ecdfa541dc449b0ea768e033dd0
+DIST catkin-0.7.5.tar.gz 202852 SHA256 a9042a1e0f7eb28241c5b3a934bbf285772604f3b030f474da85c7349fde4639 SHA512 96429cb0e18847d007b8861ebc62e200a529840ea5f5d79514998a8297028aa8c0902441bbba295d7f69b9c182d910bf7ed9cbeb6d5d61a67c715141661a7780 WHIRLPOOL 1f91f27aebd628846d444289867340dc6166e45dde5565965e8ca1bca371c2798e1d0b115d71b811e4d591f1d60df0b13c30be86c92cfbc7d52b4f1ba792d5b2
diff --git a/dev-util/catkin/catkin-0.7.5.ebuild b/dev-util/catkin/catkin-0.7.5.ebuild
new file mode 100644 (file)
index 0000000..6dda001
--- /dev/null
@@ -0,0 +1,115 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SCM="git-r3"
+       EGIT_REPO_URI="https://github.com/ros/catkin"
+fi
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ${SCM} cmake-utils python-r1 python-utils-r1
+
+DESCRIPTION="Cmake macros and associated python code used to build some parts of ROS"
+HOMEPAGE="http://wiki.ros.org/catkin"
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SRC_URI=""
+       KEYWORDS=""
+else
+       SRC_URI="https://github.com/ros/catkin/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+       dev-python/catkin_pkg[${PYTHON_USEDEP}]
+       dev-python/empy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       test? ( dev-python/nose[${PYTHON_USEDEP}] dev-python/mock[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+       "${FILESDIR}/tests.patch"
+       "${FILESDIR}/distutils.patch"
+       "${FILESDIR}/catkin_prefix_path.patch"
+       "${FILESDIR}/gnuinstalldirs.patch"
+       "${FILESDIR}/catkin_prefix_path_util_py.patch"
+       "${FILESDIR}/package_xml.patch"
+       "${FILESDIR}/etc.patch"
+)
+
+src_prepare() {
+       # fix libdir
+       sed -i \
+               -e 's:LIBEXEC_DESTINATION lib:LIBEXEC_DESTINATION libexec:' \
+               -e 's:}/lib:}/${CMAKE_INSTALL_LIBDIR}:' \
+               -e 's:DESTINATION lib):DESTINATION ${CMAKE_INSTALL_LIBDIR}):' \
+               -e 's:DESTINATION lib/:DESTINATION ${CMAKE_INSTALL_LIBDIR}/:' \
+               -e 's:PYTHON_INSTALL_DIR lib:PYTHON_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR}:' \
+               cmake/*.cmake || die
+       cmake-utils_src_prepare
+}
+
+catkin_src_configure_internal() {
+       local sitedir="$(python_get_sitedir)"
+       mycmakeargs+=(
+               -DPYTHON_EXECUTABLE="${PYTHON}"
+               -DPYTHON_INSTALL_DIR="${sitedir#${EPREFIX}/usr/}"
+       )
+       python_export PYTHON_SCRIPTDIR
+       cmake-utils_src_configure
+}
+
+src_configure() {
+       local mycmakeargs=(
+               "$(cmake-utils_use test CATKIN_ENABLE_TESTING)"
+               "-DCATKIN_BUILD_BINARY_PACKAGE=ON"
+               )
+       python_foreach_impl catkin_src_configure_internal
+}
+
+src_compile() {
+       python_foreach_impl cmake-utils_src_compile
+}
+
+src_test() {
+       unset PYTHON_SCRIPTDIR
+       python_foreach_impl cmake-utils_src_test
+}
+
+catkin_src_install_internal() {
+       python_export PYTHON_SCRIPTDIR
+       cmake-utils_src_install
+       if [ ! -f "${T}/.catkin_python_symlinks_generated" ]; then
+               dodir /usr/bin
+               for i in "${D}/${PYTHON_SCRIPTDIR}"/* ; do
+                       dosym ../lib/python-exec/python-exec2 "/usr/bin/${i##*/}" || die
+               done
+               touch "${T}/.catkin_python_symlinks_generated"
+       fi
+}
+
+src_install() {
+       python_foreach_impl catkin_src_install_internal
+
+       doenvd "${FILESDIR}/40catkin"
+
+       # needed to be considered as a workspace
+       touch "${ED}/usr/.catkin"
+}
+
+pkg_postinst() {
+       ewarn "Starting from version 0.7.1-r2, dev-util/catkin changed the"
+       ewarn "installation path for package.xml files on Gentoo."
+       ewarn "In order for ROS to work properly, you will need to reinstall ROS"
+       ewarn "packages that have it installed in the old location:"
+       ewarn "         emerge -1O /usr/share/*/package.xml"
+       ewarn "See https://bugs.gentoo.org/show_bug.cgi?id=595004 for more details."
+}