Save the repo name along with the other metadata inside dyn_compile() so that it...
authorZac Medico <zmedico@gentoo.org>
Fri, 13 Jul 2007 23:42:34 +0000 (23:42 -0000)
committerZac Medico <zmedico@gentoo.org>
Fri, 13 Jul 2007 23:42:34 +0000 (23:42 -0000)
svn path=/main/branches/2.1.2/; revision=7248

bin/ebuild.sh
pym/portage.py

index cc09080bd9d424192c761fbef7d948768d6f7bb7..d829bc0ed366b2019b3949625e87fba5d6e474ad 100755 (executable)
@@ -1008,6 +1008,7 @@ dyn_compile() {
        bzip2 -f9 environment
 
        cp "${EBUILD}" "${PF}.ebuild"
+       [ -n "${PORTAGE_REPO_NAME}" ]  && echo "${PORTAGE_REPO_NAME}" > repository
        if hasq nostrip ${FEATURES} ${RESTRICT} || hasq strip ${RESTRICT}
        then
                touch DEBUGBUILD
index 9d829de3b53b7753c9a0120c8889bb2625c8e3c3..92938eb363ef1eff29da45aa37d56f66950884eb 100644 (file)
@@ -3171,6 +3171,16 @@ def doebuild_environment(myebuild, mydo, myroot, mysettings, debug, use_cache, m
        mysettings["ROOT"]     = myroot
        mysettings["STARTDIR"] = getcwd()
 
+       mysettings["PORTAGE_REPO_NAME"] = ""
+       # bindbapi has no getRepositories() method
+       if mydbapi and hasattr(mydbapi, "getRepositories"):
+               # do we have a origin repository name for the current package
+               repopath = os.sep.join(pkg_dir.split(os.path.sep)[:-2])
+               for reponame in mydbapi.getRepositories():
+                       if mydbapi.getRepositoryPath(reponame) == repopath:
+                               mysettings["PORTAGE_REPO_NAME"] = reponame
+                               break
+
        mysettings["EBUILD"]   = ebuild_path
        mysettings["O"]        = pkg_dir
        mysettings.configdict["pkg"]["CATEGORY"] = cat
@@ -7759,19 +7769,6 @@ class dblink:
                for x in listdir(inforoot):
                        self.copyfile(inforoot+"/"+x)
 
-               # do we have a origin repository name for the current package
-               repopath = os.sep.join(self.settings["O"].split(os.sep)[:-2])
-               # bindbapi has no getRepositories() method
-               if mydbapi and hasattr(mydbapi, "getRepositories"):
-                       foundname = False
-                       for reponame in mydbapi.getRepositories():
-                               if mydbapi.getRepositoryPath(reponame) == repopath:
-                                       fd = open(os.path.join(self.dbtmpdir, "repository"), "w")
-                                       fd.write(reponame+"\n")
-                                       fd.close()
-                                       foundname = True
-                                       break
-
                # get current counter value (counter_tick also takes care of incrementing it)
                # XXX Need to make this destroot, but it needs to be initialized first. XXX
                # XXX bis: leads to some invalidentry() call through cp_all().