Remove old ebuilds, add new cvs ebuild
authorStefan Schweizer <genstef@gentoo.org>
Sat, 18 Nov 2006 20:58:06 +0000 (20:58 +0000)
committerStefan Schweizer <genstef@gentoo.org>
Sat, 18 Nov 2006 20:58:06 +0000 (20:58 +0000)
Package-Manager: portage-2.1.2_rc2

net-www/gnash/ChangeLog
net-www/gnash/files/digest-gnash-0.7.2_p20099999 [new file with mode: 0644]
net-www/gnash/gnash-0.7.2_p20099999.ebuild [new file with mode: 0644]

index f0242f11626acf3be3594355c4350a597b29a764..ea28086c16c1972fd84a1ec2915cbf8c4aec1c5d 100644 (file)
@@ -1,6 +1,15 @@
 # ChangeLog for net-www/gnash
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.28 2006/11/18 20:52:55 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.29 2006/11/18 20:58:06 genstef Exp $
+
+*gnash-0.7.2_p20099999 (18 Nov 2006)
+
+  18 Nov 2006; Stefan Schweizer <genstef@gentoo.org>
+  -files/gnash-0.7.1_p20060704-opengl.diff,
+  -files/gnash-fix-cxxflags-rpath.patch, -gnash-0.7.1_p20060704.ebuild,
+  -gnash-0.7.1_p20060814.ebuild, -gnash-0.7.1_p20099999.ebuild,
+  +gnash-0.7.2_p20099999.ebuild:
+  Remove old ebuilds, add new cvs ebuild
 
   18 Nov 2006; Stefan Schweizer <genstef@gentoo.org>
   files/digest-gnash-0.7.2, Manifest:
diff --git a/net-www/gnash/files/digest-gnash-0.7.2_p20099999 b/net-www/gnash/files/digest-gnash-0.7.2_p20099999
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/net-www/gnash/gnash-0.7.2_p20099999.ebuild b/net-www/gnash/gnash-0.7.2_p20099999.ebuild
new file mode 100644 (file)
index 0000000..1db71f5
--- /dev/null
@@ -0,0 +1,119 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.7.2_p20099999.ebuild,v 1.1 2006/11/18 20:58:06 genstef Exp $
+
+WANT_AUTOCONF=latest
+inherit nsplugins autotools cvs
+
+DESCRIPTION="Gnash is a GNU Flash movie player that supports many SWF v7 features"
+HOMEPAGE="http://www.gnu.org/software/gnash"
+#SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${PV}/${P}.tar.bz2"
+ECVS_SERVER="cvs.sv.gnu.org:/sources/${PN}"
+ECVS_MODULE="${PN}"
+[ "${PV/0.7.2_p}" != "20099999" ] && ECVS_CO_OPTS="-D ${PV/0.7.2_p}"
+ECVS_UP_OPTS="-dP ${ECVS_CO_OPTS}"
+S=${WORKDIR}/${PN}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-*"
+IUSE="agg gstreamer ffmpeg nsplugin xml video_cards_i810"
+#dmalloc, broken see bug 142939
+#dmalloc? ( dev-libs/dmalloc )
+#              $(use_enable dmalloc) \
+
+RDEPEND="
+       xml? ( dev-libs/libxml2 )
+       sys-libs/zlib
+       media-libs/jpeg
+       media-libs/libogg
+       media-libs/libpng
+       net-misc/curl
+       !ffmpeg? ( media-libs/libmad )
+       ffmpeg? ( media-video/ffmpeg )
+       gstreamer? ( media-libs/gstreamer
+               || (
+                       media-plugins/gst-plugins-ffmpeg
+                       media-plugins/gst-plugins-mad
+                       media-plugins/gst-plugins-lame
+               )
+       )
+       !gstreamer? ( media-libs/libsdl )
+       dev-libs/boost
+       || (
+               ( x11-libs/libX11
+               x11-libs/libXi
+               x11-libs/libXmu
+               x11-libs/libXt
+               x11-proto/xproto )
+               virtual/x11
+       )
+       dev-libs/atk
+       dev-libs/glib
+       >x11-libs/gtk+-2
+       x11-libs/pango
+       !agg? ( virtual/opengl x11-libs/gtkglext )
+       agg? ( x11-libs/agg )"
+       #cairo? ( x11-libs/cairo )
+
+src_unpack() {
+       cvs_src_unpack
+       cd ${S}
+       AT_M4DIR=macros AT_NO_RECURSIVE=1 eautoreconf
+       cd libltdl
+       eautoreconf
+}
+
+src_compile() {
+       local myconf
+
+       use nsplugin && myconf="${myconf} --with-plugindir=/opt/netscape/plugins"
+
+       #--enable-renderer=engine Specify rendering engine:
+       #                               OpenGL (default)
+       #                               Cairo  (experimental)
+       #cairo: does not work for plugins yet, offers flash for non-accelerated gfx?
+       #if use cairo; then
+       #       myconf="${myconf} --enable-renderer=cairo"
+       #fi
+       if use agg; then
+               myconf="${myconf} --enable-renderer=agg"
+       fi
+       #--enable-gui=flavor Specify gui flavor:
+       #                               GTK
+       #                               SDL -> has no controls, we do not USE it
+       #$(use_enable gtk glext) with USE=-gtk, fails to detect gtkglext, bug 135010
+       #--enable-sound=gst,sdl
+       if use gstreamer; then
+               myconf="${myconf} --enable-sound=gst"
+       else
+               myconf="${myconf} --enable-sound=sdl"
+       fi
+
+       if use ffmpeg; then
+               myconf="${myconf} --with-mp3-decoder=ffmpeg"
+       fi
+
+       # klash is broken, thus we do not offer it
+       econf \
+               $(use_enable nsplugin plugin) \
+               $(use_enable xml) \
+               $(use_enable video_cards_i810 i810-lod-bias) \
+               --without-gcc-arch \
+               --disable-klash \
+               ${myconf} || die "econf failed"
+       emake -j1 || die "emake failed"
+}
+
+src_install() {
+       emake DESTDIR=${D} install || die "emake install failed"
+       use nsplugin && inst_plugin /opt/netscape/plugins/libgnashplugin.so \
+               || rm -rf ${D}/opt
+       dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+       ewarn "ALPHA"
+       ewarn "gnash is still in heavy development"
+       ewarn "please report gnash bugs upstream to the gnash devs"
+}