dev-python/pyamg: Remove old
authorDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:52:10 +0000 (09:52 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:52:10 +0000 (09:52 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/pyamg/Manifest
dev-python/pyamg/pyamg-2.1.0.ebuild [deleted file]
dev-python/pyamg/pyamg-2.2.1.ebuild [deleted file]
dev-python/pyamg/pyamg-3.0.2.ebuild [deleted file]
dev-python/pyamg/pyamg-3.2.1.ebuild [deleted file]

index 2ce723dc1099256722dc7eee5957573b592a8af3..d3ed6ae9df151433ea639e9ead5e3f48838be881 100644 (file)
@@ -1,4 +1 @@
-DIST pyamg-2.1.0.tar.gz 752632 BLAKE2B 21fe8a2547d7d47c61c37d5968fd5d8a07d4e6721c2f01e063b33d760e17c37f406140e19a66b51cca6753e8114435183be6e355a97e2f6f2239b725340e085c SHA512 d2574ccb093e6c5bd214c4366ec70bfeae73449f98932a9a4435afb2d606b12a4d479411a88bcac4df500e33dbf635ae981620c584e688abc3f2cca6c6188d4d
-DIST pyamg-2.2.1.tar.gz 753299 BLAKE2B aeca4105bca1525a4c86f110c135c5505c6aa78aff04283a3b43de75c8b639ae5800b5ca9022436d40ca045700daef8a3ca6bb98edb12b223b7b10f8047cfb81 SHA512 b784626fbdfcfa338560763a38bc5ddde07ace5213225d4c876b09be93019e81e641630e88952aab20a6c4f859bf6260730459d247c35d531433df4ecd209248
-DIST pyamg-3.0.2.tar.gz 759301 BLAKE2B 35209f238540604e8a9c013df47f85a5f9dc86eb5372975e8b518352ffe0247f1ac65aaa0822ceff435d20bec87ac8b87d650c00b6b53056c6d5417fa99b0edb SHA512 3075e4e8f042e320c53fed5de7a5ccc7d9698e60cb2f830661468eabc9ba4ebbfff2b2d3254c72c5c376f0e45a59abce7b70a50f6f3a869a75096c33982d1313
 DIST pyamg-3.2.1.tar.gz 765723 BLAKE2B 72c59c0fe93363f73d8ba4c6297920dd1ca8406b048cf0357baec5f2390bdb524421a35ef65e790be45b543e9e162067ee8f8f09327b464a4bc5c9cec368b003 SHA512 6be0dd068417389934ce97813321367920abf6f9f5e94ce2df8bd796edc797cedd492c9153b62466f7d68055a05821447dcf21578ccdfe3294766a49a9ac220e
diff --git a/dev-python/pyamg/pyamg-2.1.0.ebuild b/dev-python/pyamg/pyamg-2.1.0.ebuild
deleted file mode 100644 (file)
index e1b891e..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Algebraic multigrid solvers in Python"
-HOMEPAGE="https://pyamg.github.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="sci-libs/scipy[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-python_test() {
-       distutils_install_for_testing
-       cd "${T}" || die # need to be away source directory
-       ${EPYTHON} -c "
-import pyamg, sys
-r = pyamg.test(verbose=3)
-sys.exit(0 if r.wasSuccessful() else 1)" || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/pyamg/pyamg-2.2.1.ebuild b/dev-python/pyamg/pyamg-2.2.1.ebuild
deleted file mode 100644 (file)
index 1ee8327..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Algebraic multigrid solvers in Python"
-HOMEPAGE="https://pyamg.github.io/ https://github.com/pyamg/pyamg"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/numpy[${PYTHON_USEDEP}]
-       sci-libs/scipy[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-python_test() {
-       distutils_install_for_testing
-       cd "${T}" || die # need to be away source directory
-       "${PYTHON}" "${S}"/test_pyamg_install.py || die
-}
diff --git a/dev-python/pyamg/pyamg-3.0.2.ebuild b/dev-python/pyamg/pyamg-3.0.2.ebuild
deleted file mode 100644 (file)
index 85a2cbc..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Algebraic multigrid solvers in Python"
-HOMEPAGE="https://pyamg.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/numpy[${PYTHON_USEDEP}]
-       sci-libs/scipy[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-python_test() {
-       distutils_install_for_testing
-       cd "${T}" || die # need to be away source directory
-       nosetests --verbose pyamg || die
-}
diff --git a/dev-python/pyamg/pyamg-3.2.1.ebuild b/dev-python/pyamg/pyamg-3.2.1.ebuild
deleted file mode 100644 (file)
index fe0aa61..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Algebraic multigrid solvers in Python"
-HOMEPAGE="https://pyamg.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/numpy[${PYTHON_USEDEP}]
-       sci-libs/scipy[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-python_test() {
-       distutils_install_for_testing
-       cd "${T}" || die # need to be away source directory
-       nosetests --verbose pyamg || die
-}