dev-libs/appstream-glib: Version bump
authorPacho Ramos <pacho@gentoo.org>
Sat, 5 Sep 2015 16:10:33 +0000 (18:10 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sat, 5 Sep 2015 16:10:33 +0000 (18:10 +0200)
Package-Manager: portage-2.2.20.1

dev-libs/appstream-glib/Manifest
dev-libs/appstream-glib/appstream-glib-0.5.0.ebuild [new file with mode: 0644]

index 1d4cb8f281ebb0dc42a20ffbe1285c1081760057..059eae4f666c0659125ae78000c483fb5c0727a9 100644 (file)
@@ -1,2 +1,3 @@
 DIST appstream-glib-0.3.4.tar.xz 1814472 SHA256 97b948ad992cb985e5bed533446fb5d23632397cfe2833034e11d4c6b47199da SHA512 e128609980512a4975f1226dc41300480c43f311611ac935973e850a53562f7c770622239d4dd1a2ccd88430c2a305c64927a507125f6d7761c04d8ecf0ab502 WHIRLPOOL f80edc738ca5e07255625cc4322d483c2ae753e06d1f84eed1755239c2f87aff0fd13a60bd7bae2e4f4ffecc2760a6c301e98dd085a157448e89fcd91d6e614d
 DIST appstream-glib-0.4.0.tar.xz 1837552 SHA256 f4dee0e86549009f248d38eb643061e82ff0d542f06e1f4af6b36af2f97c2e13 SHA512 54769b47f11f8792ee85ab0922d8a256800c00558ca9e2fcaab30845e3fbd9f4a08d311608f0b600f8ad070d79d5227cd9ac4b644ef6d94e1772e4695c4f1afe WHIRLPOOL da036564be55acc4c0b3d5320f165ac98d6f4754ed74dda8b06d31c7bfd91b10ff3f4ff0d85b141bfa804391befcadecd714a9b110d422cf9286c899714ad58d
+DIST appstream-glib-0.5.0.tar.xz 1818388 SHA256 35d63ca31664918905c3de634766766d98dadcd99d7271fb319f6279b846bf36 SHA512 1c1a1f41d6911c73a25a83396fb183d99ee139378766235b8885ee68c2b738137d55c108e7ea3ec2853e5ac5f17936b87df554bea45a1c19db3caea5bcee5d0d WHIRLPOOL 2a26ce1685ed3c78242c0ef29b4e5dea95ba070e531503f00f378f36974a8e1aa858b66640fe48ccc7c1ace9619671ff3c6d71aaf78e81a6ef5b55ab2be64090
diff --git a/dev-libs/appstream-glib/appstream-glib-0.5.0.ebuild b/dev-libs/appstream-glib/appstream-glib-0.5.0.ebuild
new file mode 100644 (file)
index 0000000..a1693fb
--- /dev/null
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit bash-completion-r1 gnome2
+
+DESCRIPTION="Provides GObjects and helper methods to read and write AppStream metadata"
+HOMEPAGE="http://people.freedesktop.org/~hughsient/appstream-glib/"
+SRC_URI="http://people.freedesktop.org/~hughsient/${PN}/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/7"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
+IUSE="+introspection nls"
+
+# FIXME: yaml is optional with --enable-dep11 but not
+# properly handled in autofoo bug#????
+RDEPEND="
+       app-arch/gcab
+       app-arch/libarchive
+       dev-db/sqlite:3
+       >=dev-libs/glib-2.16.1:2
+       >=media-libs/fontconfig-2.11
+       >=media-libs/freetype-2.4:2
+       >=net-libs/libsoup-2.24:2.4
+       >=x11-libs/gdk-pixbuf-2.14:2
+       x11-libs/gtk+:3
+       x11-libs/pango
+       dev-libs/libyaml
+       introspection? ( >=dev-libs/gobject-introspection-0.9.8:= )
+"
+DEPEND="${RDEPEND}
+       app-text/docbook-xml-dtd:4.3
+       dev-libs/libxslt
+       >=dev-util/gtk-doc-am-1.9
+       >=dev-util/intltool-0.40
+       >=sys-devel/gettext-0.17
+"
+# ${PN} superseeds appdata-tools, require dummy package until all ebuilds
+# are migrated to appstream-glib
+RDEPEND="${RDEPEND}
+       !<dev-util/appdata-tools-0.1.8-r1
+"
+PDEPEND=">=dev-util/appdata-tools-0.1.8-r1"
+
+src_configure() {
+       gnome2_src_configure \
+               --enable-builder \
+               --disable-ostree \
+               --disable-rpm \
+               --disable-static \
+               --enable-dep11 \
+               --enable-man \
+               $(use_enable nls) \
+               $(use_enable introspection) \
+               --with-bashcompletiondir="$(get_bashcompdir)"
+}