sys-kernel/linux-firmware: Update snapshot
authorManuel Rüger <mrueg@gentoo.org>
Tue, 22 Jan 2019 14:33:49 +0000 (15:33 +0100)
committerManuel Rüger <mrueg@gentoo.org>
Tue, 22 Jan 2019 14:34:14 +0000 (15:34 +0100)
Package-Manager: Portage-2.3.57, Repoman-2.3.12
Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
sys-kernel/linux-firmware/Manifest
sys-kernel/linux-firmware/linux-firmware-20190118.ebuild [new file with mode: 0644]

index 66b7d85fd498fc6927c2aa16a632d681335ee4b7..71563ec95ce2b13bef5d7559197d2e510e78286e 100644 (file)
@@ -2,3 +2,4 @@ DIST linux-firmware-20181026.tar.gz 167486645 BLAKE2B 9923b9a8ab692023022d7bceb2
 DIST linux-firmware-20181216.tar.gz 172681622 BLAKE2B 3d98af002e5ab1ba8935a8716273311cb9f8f52462724882dc6bf63d96ac17011f3b68c37a87eb6e7447f1542b289fcd7afd3b4bbe21afa3aa63c7c2a2fa0ec8 SHA512 fd1790571a744ebbde7ac163ab86bdbe0476f5b3774e3a129eaac850207b146e5b537c7c1c01535c8813215274c9ce02ca9efe1cffe2406fb922f764adbf1a02
 DIST linux-firmware-20181218.tar.gz 174835447 BLAKE2B 8bac1dbd413c4fc5c8c07bb299860504cf9ec39b3665e20d86c3755c2a655a5bd4508b406d91fe8648378217bc3aa49fdac05beafd31dcbc0a05496a195d1deb SHA512 58bb759378e569169a4499e5b0e09b7aa3e42a160b1187313fd8e74b4d26e45a018202c2dfd94b7b592cb0a5ad040bbd4051a0f74d7737aa3a72f0e3ed060dfc
 DIST linux-firmware-20190114.tar.gz 175568625 BLAKE2B 1d89ed002293343dc448acb97bf047b99752661d7a358d8ea0f8d2fcce5331af85cde0717861fc429e71aa89647189476df0c92ebfc8edb75c2954e56d8a1860 SHA512 05df281667402b3265f401b3845c4ead22521c8c82f9a48a7fb15dbfaadaacce9fb9ca0e17c521c8928e7a82a7e170cc339697b8fbae8b89798a1f0daf9846da
+DIST linux-firmware-20190118.tar.gz 175570644 BLAKE2B 4d1492e820c2f03ab47068be4a8f343cbee62ab18fc72849a4edfa8a0afd5f3ed131f95efa578177155d8e31b7d4283567661855ee693566710934588ef65511 SHA512 2cc06f179c4a720a43f6fbf634b169bd664ec1740cff86abc78de4f30b49e5bd280f5134975a55a2d20f442a4bd72a91cc228ad23ef8c5bc67c7a08e1c0e9658
diff --git a/sys-kernel/linux-firmware/linux-firmware-20190118.ebuild b/sys-kernel/linux-firmware/linux-firmware-20190118.ebuild
new file mode 100644 (file)
index 0000000..7f6679a
--- /dev/null
@@ -0,0 +1,135 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit savedconfig
+
+if [[ ${PV} == 99999999* ]]; then
+       inherit git-r3
+       SRC_URI=""
+       EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/firmware/${PN}.git"
+else
+       GIT_COMMIT="a8b75cac06f80dc1500ba385680ac5b5c1d1c4f8"
+       SRC_URI="https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/snapshot/linux-firmware-${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="Linux firmware files"
+HOMEPAGE="https://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git"
+
+LICENSE="linux-firmware ( BSD ISC MIT no-source-code ) GPL-2 GPL-2+ freedist"
+SLOT="0"
+IUSE="savedconfig"
+
+DEPEND=""
+RDEPEND="!savedconfig? (
+               !sys-firmware/alsa-firmware[alsa_cards_ca0132]
+               !sys-firmware/alsa-firmware[alsa_cards_korg1212]
+               !sys-firmware/alsa-firmware[alsa_cards_maestro3]
+               !sys-firmware/alsa-firmware[alsa_cards_sb16]
+               !sys-firmware/alsa-firmware[alsa_cards_ymfpci]
+               !media-tv/cx18-firmware
+               !<sys-firmware/ivtv-firmware-20080701-r1
+               !media-tv/linuxtv-dvb-firmware[dvb_cards_cx231xx]
+               !media-tv/linuxtv-dvb-firmware[dvb_cards_cx23885]
+               !media-tv/linuxtv-dvb-firmware[dvb_cards_usb-dib0700]
+               !net-dialup/ueagle-atm
+               !net-dialup/ueagle4-atm
+               !net-wireless/ar9271-firmware
+               !net-wireless/i2400m-fw
+               !net-wireless/libertas-firmware
+               !sys-firmware/rt61-firmware
+               !net-wireless/rt73-firmware
+               !net-wireless/rt2860-firmware
+               !net-wireless/rt2870-firmware
+               !sys-block/qla-fc-firmware
+               !sys-firmware/amd-ucode
+               !sys-firmware/iwl1000-ucode
+               !sys-firmware/iwl2000-ucode
+               !sys-firmware/iwl2030-ucode
+               !sys-firmware/iwl3945-ucode
+               !sys-firmware/iwl4965-ucode
+               !sys-firmware/iwl5000-ucode
+               !sys-firmware/iwl5150-ucode
+               !sys-firmware/iwl6000-ucode
+               !sys-firmware/iwl6005-ucode
+               !sys-firmware/iwl6030-ucode
+               !sys-firmware/iwl6050-ucode
+               !sys-firmware/iwl3160-ucode
+               !sys-firmware/iwl7260-ucode
+               !sys-firmware/iwl7265-ucode
+               !sys-firmware/iwl3160-7260-bt-ucode
+               !sys-firmware/radeon-ucode
+       )"
+#add anything else that collides to this
+
+RESTRICT="binchecks strip"
+
+src_unpack() {
+       if [[ ${PV} == 99999999* ]]; then
+               git-r3_src_unpack
+       else
+               default
+               # rename directory from git snapshot tarball
+               mv ${PN}-*/ ${P} || die
+       fi
+}
+
+src_prepare() {
+       default
+
+       echo "# Remove files that shall not be installed from this list." > ${PN}.conf
+       find * \( \! -type d -and \! -name ${PN}.conf \) >> ${PN}.conf
+
+       if use savedconfig; then
+               restore_config ${PN}.conf
+               ebegin "Removing all files not listed in config"
+
+               local file delete_file preserved_file preserved_files=()
+
+               while IFS= read -r file; do
+                       # Ignore comments.
+                       if [[ ${file} != "#"* ]]; then
+                               preserved_files+=("${file}")
+                       fi
+               done < ${PN}.conf || die
+
+               while IFS= read -d "" -r file; do
+                       delete_file=true
+                       for preserved_file in "${preserved_files[@]}"; do
+                               if [[ "${file}" == "${preserved_file}" ]]; then
+                                       delete_file=false
+                               fi
+                       done
+
+                       if ${delete_file}; then
+                               rm "${file}" || die
+                       fi
+               done < <(find * \( \! -type d -and \! -name ${PN}.conf \) -print0 || die)
+
+               eend || die
+
+               # remove empty directories, bug #396073
+               find -type d -empty -delete || die
+       fi
+}
+
+src_install() {
+       if use !savedconfig; then
+               save_config ${PN}.conf
+       fi
+       rm ${PN}.conf || die
+       insinto /lib/firmware/
+       doins -r *
+}
+
+pkg_preinst() {
+       if use savedconfig; then
+               ewarn "USE=savedconfig is active. You must handle file collisions manually."
+       fi
+}
+
+pkg_postinst() {
+       elog "If you are only interested in particular firmware files, edit the saved"
+       elog "configfile and remove those that you do not want."
+}