app-crypt/certbot-apache: fix tests (use pytest instead of nose)
authorMatthew Thode <prometheanfire@gentoo.org>
Sun, 19 Apr 2020 18:30:46 +0000 (13:30 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Sun, 19 Apr 2020 18:31:05 +0000 (13:31 -0500)
pytest is what upstream uses, so use it here too

Closes: https://bugs.gentoo.org/718130
Package-Manager: Portage-2.3.89, Repoman-2.3.20
RepoMan-Options: --force
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-crypt/certbot-apache/certbot-apache-1.3.0-r1.ebuild [moved from app-crypt/certbot-apache/certbot-apache-1.3.0.ebuild with 94% similarity]
app-crypt/certbot-apache/certbot-apache-9999.ebuild

similarity index 94%
rename from app-crypt/certbot-apache/certbot-apache-1.3.0.ebuild
rename to app-crypt/certbot-apache/certbot-apache-1.3.0-r1.ebuild
index d454271a63c7696f8d5c2c63de51864c8aed4d10..3ef09260e7249b7ccfdb830d3dd8ec69a5ae26b8 100644 (file)
@@ -31,9 +31,9 @@ RDEPEND=">=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
        dev-python/zope-component[${PYTHON_USEDEP}]
        dev-python/zope-interface[${PYTHON_USEDEP}]"
 DEPEND="test? ( ${RDEPEND}
-       dev-python/nose[${PYTHON_USEDEP}] )
+       dev-python/pytest[${PYTHON_USEDEP}] )
        dev-python/setuptools[${PYTHON_USEDEP}]"
 
 python_test() {
-       nosetests || die
+       esetup.py test || die
 }
index 56e71bffc58212ed219c1a71dead9589de7c0ba3..499084cf93b1ca5703e7bb5cbd9be2a6fd0a5c32 100644 (file)
@@ -31,9 +31,9 @@ RDEPEND=">=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
        dev-python/zope-component[${PYTHON_USEDEP}]
        dev-python/zope-interface[${PYTHON_USEDEP}]"
 DEPEND="test? ( ${RDEPEND}
-       dev-python/nose[${PYTHON_USEDEP}] )
+       dev-python/pytest[${PYTHON_USEDEP}] )
        dev-python/setuptools[${PYTHON_USEDEP}]"
 
 python_test() {
-       nosetests || die
+       esetup.py test || die
 }