malloc.h should not be included, stdlib.h instead should.
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Sat, 7 Oct 2006 19:20:27 +0000 (19:20 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Sat, 7 Oct 2006 19:20:27 +0000 (19:20 +0000)
Package-Manager: portage-2.1.2_pre2-r5

app-arch/lha/ChangeLog
app-arch/lha/files/lha-114i-malloc.patch
app-arch/lha/lha-114i-r5.ebuild

index 02f1fdcd3ad826969e39162169655ba08067d74a..a3cca32e0de17c1eaf2c66c14238c3fbd968c5fe 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for app-arch/lha
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lha/ChangeLog,v 1.25 2005/10/30 20:14:52 grobian Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lha/ChangeLog,v 1.26 2006/10/07 19:20:27 flameeyes Exp $
+
+  07 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
+  files/lha-114i-malloc.patch, lha-114i-r5.ebuild:
+  malloc.h should not be included, stdlib.h instead should.
 
   30 Oct 2005; Fabian Groffen <grobian@gentoo.org>
   files/lha-114i-build.patch, files/lha-114i-malloc.patch:
index 8c9d968a9d5812995c28bbb2c52342bda2785a72..2a2a0daf045cd5f28d368dda5a82a356460a016a 100644 (file)
@@ -1,12 +1,10 @@
 --- lha-114i/src/lha.h
 +++ lha-114i/src/lha.h
-@@ -16,6 +16,9 @@
+@@ -16,6 +16,7 @@
  #include <sys/types.h>
  #include <sys/file.h>
  #include <sys/stat.h>
-+#ifndef __APPLE__
-+#include <malloc.h>
-+#endif
++#include <stdlib.h>
  
  #include <signal.h>
  
index f4ece19666bc0389ea1c7c3fc3450211fdbf55bb..29f38f781d9d0115aa8fe33c86676fa261435c58 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lha/lha-114i-r5.ebuild,v 1.2 2006/09/03 06:09:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lha/lha-114i-r5.ebuild,v 1.3 2006/10/07 19:20:27 flameeyes Exp $
 
 inherit eutils flag-o-matic
 
@@ -10,7 +10,7 @@ SRC_URI="http://www2m.biglobe.ne.jp/~dolphin/lha/prog/${P}.tar.gz"
 
 LICENSE="lha"
 SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ppc ppc-macos ppc64 s390 sh sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ppc ppc-macos ppc64 s390 sh sparc x86 ~x86-fbsd"
 IUSE=""
 
 DEPEND=""