x11-plugins/wmacpi: fix build with -fno-common
authorBernard Cafarelli <voyageur@gentoo.org>
Sun, 29 Mar 2020 11:13:14 +0000 (13:13 +0200)
committerBernard Cafarelli <voyageur@gentoo.org>
Sun, 29 Mar 2020 11:35:24 +0000 (13:35 +0200)
Latest libdockapp revbump now defines a global variable as extern

Closes: https://bugs.gentoo.org/715260
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
x11-plugins/wmacpi/files/wmacpi-2.3-fno-common.patch [new file with mode: 0644]
x11-plugins/wmacpi/wmacpi-2.3-r2.ebuild [new file with mode: 0644]

diff --git a/x11-plugins/wmacpi/files/wmacpi-2.3-fno-common.patch b/x11-plugins/wmacpi/files/wmacpi-2.3-fno-common.patch
new file mode 100644 (file)
index 0000000..068c00c
--- /dev/null
@@ -0,0 +1,11 @@
+diff -Naur dockapps.orig/wmacpi.c dockapps/wmacpi.c
+--- dockapps.orig/wmacpi.c     2015-01-12 11:24:15.000000000 +0100
++++ dockapps/wmacpi.c  2020-03-29 13:11:56.712022800 +0200
+@@ -72,6 +72,7 @@
+ /* globals */
+ struct dockapp *dockapp;
++Display *display;
+ /* global_t *globals; */
+ /* this gives us a variable scroll rate, depending on the importance of the
diff --git a/x11-plugins/wmacpi/wmacpi-2.3-r2.ebuild b/x11-plugins/wmacpi/wmacpi-2.3-r2.ebuild
new file mode 100644 (file)
index 0000000..25640e9
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="DockApp ACPI status monitor for laptops"
+HOMEPAGE="https://www.dockapps.net/wmacpi"
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 -ppc -sparc ~x86"
+
+DEPEND=">=x11-libs/libdockapp-0.7-r1:=
+       x11-libs/libX11"
+
+S=${WORKDIR}/dockapps
+
+PATCHES=(
+       "${FILESDIR}"/${P}-makefile.patch
+       "${FILESDIR}"/${P}-fno-common.patch
+       )
+
+src_prepare() {
+       default
+
+       sed -e 's#<dockapp.h>#<libdockapp/dockapp.h>#' -i *.c || die
+}
+
+src_compile() {
+       emake CC="$(tc-getCC)"
+}