Version bumped. Removed old ebuilds.
authorMamoru Komachi <usata@gentoo.org>
Tue, 7 Nov 2006 05:48:52 +0000 (05:48 +0000)
committerMamoru Komachi <usata@gentoo.org>
Tue, 7 Nov 2006 05:48:52 +0000 (05:48 +0000)
Package-Manager: portage-2.1.2_rc1-r4

net-im/micq/ChangeLog
net-im/micq/files/digest-micq-0.5.2 [new file with mode: 0644]
net-im/micq/micq-0.5.2.ebuild [new file with mode: 0644]

index a764def8dbbc6a0c5c72583bf7bcdeb5c0d34bed..aa9a401b03c2af79b8feb8e3e3378bf79fb08c98 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-im/micq
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/micq/ChangeLog,v 1.39 2006/02/08 12:57:45 reb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/micq/ChangeLog,v 1.40 2006/11/07 05:48:52 usata Exp $
+
+*micq-0.5.2 (07 Nov 2006)
+
+  07 Nov 2006; Mamoru KOMACHI <usata@gentoo.org> -micq-0.5.0.1.ebuild,
+  -micq-0.5.0.4.ebuild, +micq-0.5.2.ebuild:
+  Version bumped. Removed old ebuilds.
 
 *micq-0.5.1 (08 Feb 2006)
 
diff --git a/net-im/micq/files/digest-micq-0.5.2 b/net-im/micq/files/digest-micq-0.5.2
new file mode 100644 (file)
index 0000000..ed5fc07
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 ca39b53627a251a65e6bcee16924ac19 micq-0.5.2.tgz 1118332
+RMD160 40010243c3b5a3fc4c2e8ffe02a5da8132de96b9 micq-0.5.2.tgz 1118332
+SHA256 97dc4a1cc2d6063c32a9a278a0ad919d5902b0285dee23868df59644df10dc08 micq-0.5.2.tgz 1118332
diff --git a/net-im/micq/micq-0.5.2.ebuild b/net-im/micq/micq-0.5.2.ebuild
new file mode 100644 (file)
index 0000000..5971249
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/micq/micq-0.5.2.ebuild,v 1.1 2006/11/07 05:48:52 usata Exp $
+
+IUSE="tcltk ssl"
+
+SRC_URI="http://www.micq.org/source/${P}.tgz"
+DESCRIPTION="ICQ text-mode client with many features"
+HOMEPAGE="http://www.micq.org/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+DEPEND="virtual/libc
+       ssl? ( >=net-libs/gnutls-0.8.10
+               dev-libs/openssl )
+       tcltk? ( dev-lang/tcl )"
+
+src_compile() {
+
+       econf `use_enable tcltk tcl` \
+               `use_enable ssl` \
+               || die "econf failed"
+       emake || die
+}
+
+src_install() {
+
+       make DESTDIR=${D} install || die
+
+       dodoc COPYING AUTHORS ChangeLog FAQ INSTALL NEWS README TODO
+}