dev-python/entrypoints: Drop 0.2.3 and 0.3 (r0)
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 12 Mar 2020 15:35:51 +0000 (16:35 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 12 Mar 2020 15:41:59 +0000 (16:41 +0100)
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/entrypoints/Manifest
dev-python/entrypoints/entrypoints-0.2.3.ebuild [deleted file]
dev-python/entrypoints/entrypoints-0.3.ebuild [deleted file]
dev-python/entrypoints/files/entrypoints-0.2.3-setup.py.patch [deleted file]

index 4c2a46869486024a85b0b5a54974ef5b951ecea4..94566c08165044860c38f46c6c0e83f52d9b9a13 100644 (file)
@@ -1,2 +1 @@
-DIST entrypoints-0.2.3.tar.gz 11219 BLAKE2B ae7745a075d564b3cc25a0580ae9f30f6e1a0b4bca7315c4fc3700408e4ab3762831212a451eb937ab94096d1db5c1478980b216dea7cfb95a8577d6337534a0 SHA512 dbf8085652e50cbdbe137ae655ef765cff58bdaa6beefebf1383dcd96dfcbf9c92580c09e9a58de7893aebdd7b2a701ef8d13a56ef0fa9a3d9ef7a5bd1d9b11b
 DIST entrypoints-0.3.tar.gz 12315 BLAKE2B f548d98eeb9dcf5760b26f66e5dec0849c9a9027cd68447c07a585e7b80f79a7c66712d0dd270b6960db167d26f9cf0c9c221edd21f2692c2221d36e952ede65 SHA512 aa1274362d3a4b00266103319ca51aa266605b4999c89a9d0673eb61bfae9e646cb0ec6b86c95544493f6fe048385a2c7641d64adca8f45815546fb1e663c858
diff --git a/dev-python/entrypoints/entrypoints-0.2.3.ebuild b/dev-python/entrypoints/entrypoints-0.2.3.ebuild
deleted file mode 100644 (file)
index 6196761..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Discover and load entry points from installed packages"
-HOMEPAGE="https://github.com/takluyver/entrypoints"
-SRC_URI="https://github.com//takluyver/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '>=dev-python/configparser-3.5.0[${PYTHON_USEDEP}]' 'python2*')
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-               virtual/python-pathlib[${PYTHON_USEDEP}]
-       )
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       "
-
-PATCHES=(
-       "${FILESDIR}/${P}"-setup.py.patch
-       "${FILESDIR}/${PN}"-0.2.1-init.py.patch
-)
-
-python_prepare_all() {
-       # Prevent un-needed download during build
-       if use doc; then
-               sed -e "/^    'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
-       fi
-
-       distutils-r1_python_prepare_all
-
-       mv "${WORKDIR}/${P}"/entrypoints.py "${WORKDIR}/${P}/${PN}/" || die
-}
-
-python_compile_all() {
-       if use doc; then
-               emake -C doc html
-               HTML_DOCS=( doc/_build/html/. )
-       fi
-}
-
-python_test() {
-       distutils_install_for_testing
-       cd "${TEST_DIR}"/lib || die
-       cp -r "${S}"/tests "${TEST_DIR}"/lib/ || die
-       py.test || die
-}
diff --git a/dev-python/entrypoints/entrypoints-0.3.ebuild b/dev-python/entrypoints/entrypoints-0.3.ebuild
deleted file mode 100644 (file)
index 7d70104..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Discover and load entry points from installed packages"
-HOMEPAGE="https://github.com/takluyver/entrypoints"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="doc test"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '>=dev-python/configparser-3.5.0[${PYTHON_USEDEP}]' 'python2*')
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-               virtual/python-pathlib[${PYTHON_USEDEP}]
-       )
-"
-
-RESTRICT="!test? ( test )"
-
-PATCHES=(
-       "${FILESDIR}/${PN}"-0.2.1-init.py.patch
-)
-
-python_prepare_all() {
-       # Prevent un-needed download during build
-       if use doc; then
-               sed -e "/^    'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
-       fi
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               emake -C doc html
-               HTML_DOCS=( doc/_build/html/. )
-       fi
-}
-
-python_test() {
-       distutils_install_for_testing
-       cd "${TEST_DIR}"/lib || die
-       cp -r "${S}"/tests "${TEST_DIR}"/lib/ || die
-       py.test || die
-}
diff --git a/dev-python/entrypoints/files/entrypoints-0.2.3-setup.py.patch b/dev-python/entrypoints/files/entrypoints-0.2.3-setup.py.patch
deleted file mode 100644 (file)
index 7ed226b..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-setup.py for entrypoints by Marius Brehler <marbre@linux.sungazer.de>.
-
-Patch by Marius Brehler <marbrbre@linux.sungazer.de>.
---- /dev/null
-+++ b/setup.py
-@@ -0,0 +1,13 @@
-+from distutils.core import setup
-+
-+setup(name='entrypoints',
-+      version='0.2.3',
-+      description='Discover and load entry points from installed packages.',
-+      author='Thomas Kluyver',
-+      author_email='thomas@kluyver.me.uk',
-+      url='https://github.com/takluyver/entrypoints',
-+      packages=['entrypoints'],
-+      classifiers=[
-+          'License :: OSI Approved :: MIT License'
-+      ]
-+)
-\ No newline at end of file