app-xemacs/ebuild-mode: Version bump to 1.48.
authorUlrich Müller <ulm@gentoo.org>
Wed, 11 Dec 2019 19:22:30 +0000 (20:22 +0100)
committerUlrich Müller <ulm@gentoo.org>
Wed, 11 Dec 2019 19:24:29 +0000 (20:24 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-xemacs/ebuild-mode/Manifest
app-xemacs/ebuild-mode/ebuild-mode-1.48.ebuild [new file with mode: 0644]

index 4bb9466f5749d605443461edcc7c4a7fd71dc631..6646fa08e43664919f781361fd36b55b95dfb7dd 100644 (file)
@@ -1,2 +1,3 @@
 DIST ebuild-mode-1.46.tar.xz 34928 BLAKE2B ee2686f3862fc7aa5f820311a6e45d62b153426134422c56a2a6222795163f454291da5510e86c52edee1b22b7bec641ceb132147b29243ee647774a8e91342b SHA512 e7a81c9a3692db1c6db41e138b382e3027094529d4ad3244ecde5a245340f911f8a63ce8ce8bbd7910116c704bcf8fcce90142b8863ecc1b543760ef1411833e
 DIST ebuild-mode-1.47.tar.xz 34812 BLAKE2B abbc3be110239f9e1765d4f1293856a7fc616d497ac5256a28b7d78fc57c8d725abccbf7b9e5908cb85f9a684dc1be26ab88152d836c2ec3a481802091729717 SHA512 13ee756ef914a314f6705df78735a3926a50d156f4abeff917bed68298aec81f072d53a60f7b985d9bb2caddcdbf65fd26f6c9189e6c5c1822674d9142b7db17
+DIST ebuild-mode-1.48.tar.xz 34764 BLAKE2B cd54e8a1b65232538924aafd10f6dcadd457634313ccf08c97b841d0255f02496a0e3308a4d9cdcd5cbbc41f9f5c373e14641fa31202cfa369fd10f8562cf5da SHA512 d37d7951030877454416dca761c9775eadaa514f29bba8745f61c0f3a5ecb42675c230301286d5a8cce76d8ef7082f5db76151f69b35f6a999118c5e60a5f9c0
diff --git a/app-xemacs/ebuild-mode/ebuild-mode-1.48.ebuild b/app-xemacs/ebuild-mode/ebuild-mode-1.48.ebuild
new file mode 100644 (file)
index 0000000..ad5a9cc
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xemacs-elisp
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+RDEPEND=">=app-editors/xemacs-21.4.20-r5
+       app-xemacs/sh-script"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+       ${XEMACS_BATCH_CLEAN} -eval "(add-to-list 'load-path \".\")" \
+               -f batch-byte-compile ebuild-mode.el gentoo-newsitem-mode.el || die
+       xemacs-elisp-make-autoload-file \
+               ebuild-mode.el gentoo-newsitem-mode.el || die
+}