media-libs/plib: Rev bump to bump EAPI to EAPI=6
authorThomas Deutschmann <whissi@gentoo.org>
Fri, 23 Feb 2018 21:52:17 +0000 (22:52 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Fri, 23 Feb 2018 21:52:35 +0000 (22:52 +0100)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

media-libs/plib/files/plib-1.8.5-X11-r1.patch [new file with mode: 0644]
media-libs/plib/plib-1.8.5-r2.ebuild [new file with mode: 0644]

diff --git a/media-libs/plib/files/plib-1.8.5-X11-r1.patch b/media-libs/plib/files/plib-1.8.5-X11-r1.patch
new file mode 100644 (file)
index 0000000..7c19d15
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/configure.in
++++ b/configure.in
+@@ -276,7 +276,7 @@
+         LDFLAGS="$LDFLAGS $X_LIBS"
+-        LIBS="$LIBS $X_PRE_LIBS -lXi -lXmu -lXext -lX11 $X_EXTRA_LIBS -lm"
++        LIBS="$LIBS $X_PRE_LIBS -lX11 $X_EXTRA_LIBS -lm"
+ dnl =========================================================
+ dnl    if test "x$x_includes" != "x"; then
diff --git a/media-libs/plib/plib-1.8.5-r2.ebuild b/media-libs/plib/plib-1.8.5-r2.ebuild
new file mode 100644 (file)
index 0000000..d3ca9fa
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit flag-o-matic autotools
+
+DESCRIPTION="multimedia library used by many games"
+HOMEPAGE="http://plib.sourceforge.net/"
+SRC_URI="http://plib.sourceforge.net/dist/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+
+DEPEND="virtual/opengl"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+       "${FILESDIR}"/${P}-X11-r1.patch
+       "${FILESDIR}"/${P}-CVE-2011-4620.patch
+       "${FILESDIR}"/${P}-CVE-2012-4552.patch
+)
+
+src_prepare() {
+       default
+
+       mv configure.in configure.ac || die
+
+       eautoreconf
+
+       # Since plib only provides static libraries, force
+       # building as PIC or plib is useless to amd64/etc...
+       append-flags -fPIC
+}
+
+src_install() {
+       DOCS=( AUTHORS ChangeLog KNOWN_BUGS NOTICE README* TODO* )
+
+       default
+}