xfce-base/xfce4-settings: Bump to 4.13.6
authorMichał Górny <mgorny@gentoo.org>
Sat, 18 May 2019 06:13:44 +0000 (08:13 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 18 May 2019 06:52:33 +0000 (08:52 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
xfce-base/xfce4-settings/Manifest
xfce-base/xfce4-settings/metadata.xml
xfce-base/xfce4-settings/xfce4-settings-4.13.6.ebuild [new file with mode: 0644]

index 9a979eb0cfc66043a865b3e59d2f12dbb46125bb..c7ea00e4500db20d17e96ef8b3416f5890952692 100644 (file)
@@ -1,2 +1,3 @@
 DIST xfce4-settings-4.12.4.tar.bz2 1036773 BLAKE2B 512547a172081d75e7eeb97f499e77320a3df1090e80ef548dbbaf84d454b614ddb6a36bbfe4cd06d18b478ada7bd76f385dde374a93380f848ffcc232b133d3 SHA512 9b74daa3f98f15c8cb696dc79f9913fecb37f2ca44c2fd3f24865ae03e9a1db93cb5a8ddb27da3c4af7d7a9e9d718a22e46188ff515caf925a5cedfaab37b189
 DIST xfce4-settings-4.13.5.tar.bz2 1067538 BLAKE2B e1c747582744bd2102f46fa45340d5695240f98941ebe55a83067b9c99b00946b8df9c522313418219acd11048d49b8c6617abde64eb3dce583be59c9272ade3 SHA512 5e7b13b25767091ab0b1a5683359f33e4a86151dd9321681fc4d896fcd9cc569effaebfbab70bc734e07041e9fbb1c3015f9a177146de8a128c4a539462dba5e
+DIST xfce4-settings-4.13.6.tar.bz2 1163147 BLAKE2B 28986789cb82f91dd70d33203503cf49c4e20b548722be3cb8a2214ea16b762841cd56ad0ff7fc106b8ee35c812a7b455076c8fdce79aa7bf84e7706c15bd3ab SHA512 7fe4655a5644dec8688eebc508e23bace7af76c6b8eeb3821fa9a4ec79862cde64cf59ee2ac70a27ff378ef887ce6d109ef1b1d9e5f7e98f96fdb43604e024b6
index 12f76d9d6a2e4f53ddc3007171447d0e46f794fa..b09a58d88e8ed8ec917816d13067f5c6fcce62a7 100644 (file)
@@ -6,6 +6,7 @@
     <name>XFCE Team</name>
   </maintainer>
   <use>
+    <flag name="colord">Support color management using <pkg>x11-misc/colord</pkg></flag>
     <flag name="libcanberra">Enable sound event support using <pkg>media-libs/libcanberra</pkg></flag>
     <flag name="xklavier">Enable keyboard layout selection support using <pkg>x11-libs/libxklavier</pkg></flag>
   </use>
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.13.6.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.13.6.ebuild
new file mode 100644 (file)
index 0000000..35cda5e
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+DESCRIPTION="Configuration system for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="colord input_devices_libinput libcanberra libnotify upower +xklavier"
+
+RDEPEND="
+       >=dev-libs/glib-2.24
+       media-libs/fontconfig
+       x11-libs/gtk+:3
+       x11-libs/libX11
+       >=x11-libs/libXcursor-1.1
+       >=x11-libs/libXi-1.3
+       >=x11-libs/libXrandr-1.2
+       >=xfce-base/garcon-0.2
+       >=xfce-base/exo-0.11
+       >=xfce-base/libxfce4ui-4.12
+       >=xfce-base/libxfce4util-4.12
+       >=xfce-base/xfconf-4.13
+       colord? ( x11-misc/colord:= )
+       libcanberra? ( >=media-libs/libcanberra-0.25[sound] )
+       input_devices_libinput? ( x11-drivers/xf86-input-libinput )
+       libnotify? ( >=x11-libs/libnotify-0.7 )
+       upower? ( >=sys-power/upower-0.9.23 )
+       xklavier? ( >=x11-libs/libxklavier-5 )"
+DEPEND="${RDEPEND}
+       dev-util/gdbus-codegen
+       dev-util/intltool
+       virtual/pkgconfig
+       sys-devel/gettext
+       x11-base/xorg-proto"
+
+src_configure() {
+       local myconf=(
+               $(use_enable upower upower-glib)
+               $(use_enable input_devices_libinput xorg-libinput)
+               $(use_enable libnotify)
+               $(use_enable colord)
+               $(use_enable xklavier libxklavier)
+               $(use_enable libcanberra sound-settings)
+       )
+       econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+}