app-arch/lxqt-archiver: add version 0.2.0 (new package)
authorJimi Huotari <chiitoo@gentoo.org>
Mon, 27 Apr 2020 19:44:45 +0000 (22:44 +0300)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 20 May 2020 23:28:34 +0000 (01:28 +0200)
A graphical Qt front-end for several archive formats, part of the
LXQt project.

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-arch/lxqt-archiver/Manifest [new file with mode: 0644]
app-arch/lxqt-archiver/lxqt-archiver-0.2.0.ebuild [new file with mode: 0644]
app-arch/lxqt-archiver/metadata.xml [new file with mode: 0644]

diff --git a/app-arch/lxqt-archiver/Manifest b/app-arch/lxqt-archiver/Manifest
new file mode 100644 (file)
index 0000000..186a263
--- /dev/null
@@ -0,0 +1 @@
+DIST lxqt-archiver-0.2.0.tar.xz 155912 BLAKE2B e5c92d5939d3e6d42a79804596e9acc67b007126b630cd9317df7d0d07bb8f3e27cf9ecf6e16eef3289d31ef3627b4fa870cdb5eb52a36489df1080b03509acd SHA512 478a04d0e6e4601dc342ae260c5db4178b01191cae263154dbe400b394e5cd4cb9cd8a6bab7e7c59af57d6bf20c47a5ad2663a85d0eab5f71fbaf584f7588fd7
diff --git a/app-arch/lxqt-archiver/lxqt-archiver-0.2.0.ebuild b/app-arch/lxqt-archiver/lxqt-archiver-0.2.0.ebuild
new file mode 100644 (file)
index 0000000..dd4a15a
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt GUI File Archiver"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} == *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+       SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+       dev-qt/linguist-tools:5
+       >=dev-util/lxqt-build-tools-0.7.0
+"
+DEPEND="
+       dev-libs/json-glib
+       dev-qt/qtcore:5
+       dev-qt/qtgui:5
+       dev-qt/qtwidgets:5
+       dev-qt/qtx11extras:5
+       >=x11-libs/libfm-qt-0.15.0
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+       xdg_desktop_database_update
+
+       elog "Please note that this is only a graphical front-end, and additional"
+       elog "packages are needed to have support for specific file formats."
+       elog "For example, to be able to work with the 7-Zip format, the"
+       elog "'app-arch/p7zip' package may be used."
+       elog "For the full list of supported formats, see the 'README.md' file:"
+       elog "https://github.com/lxqt/lxqt-archiver/blob/master/README.md"
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+}
diff --git a/app-arch/lxqt-archiver/metadata.xml b/app-arch/lxqt-archiver/metadata.xml
new file mode 100644 (file)
index 0000000..19d4de8
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="project">
+    <email>lxqt@gentoo.org</email>
+    <name>LXQt</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="github">lxqt/lxqt-archiver</remote-id>
+  </upstream>
+</pkgmetadata>