net-fs/cifs-utils: Fixed installation with MAKEOPTS="-j1"
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 8 Apr 2020 07:00:25 +0000 (09:00 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 8 Apr 2020 07:06:17 +0000 (09:06 +0200)
which has a somewhat inverted race condition.

Reported-by: Jeroen Roovers <jer@gentoo.org>
Tested-by: Jeroen Roovers <jer@gentoo.org>
Closes: https://bugs.gentoo.org/716648
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-fs/cifs-utils/files/cifs-utils-6.10-ln_in_destdir.patch

index b2c00bf500db81ba39a226c67f5ca0fec96de708..6952d72cf5c46be58b865d398c6b2e1bbab29081 100644 (file)
@@ -1,14 +1,25 @@
+Fix sandbox violation caused by calling ln in /sbin instead of $(DESTDIR)/sbin
+
+Also fixed an inverted race condition when installing with MAKEOPTS="-j1"
+
+jer found this:
+  install-root_sbinPROGRAMS is called from install-data-am but
+  install-exec-hook is called from install-exec-am
+
+So moving the failing ln call into install-data-hook for now...
+
 --- cifs-utils-6.10/Makefile.am
 +++ cifs-utils-6.10/Makefile.am
-@@ -119,10 +119,10 @@
+@@ -118,11 +118,9 @@
  SUBDIRS = contrib
  
- install-exec-hook:
+-install-exec-hook:
 -      (cd $(ROOTSBINDIR) && ln -sf mount.cifs mount.smb3)
-+      (cd $(DESTDIR)$(ROOTSBINDIR) && ln -sf mount.cifs mount.smb3)
+-
  install-data-hook:
 -      (cd $(man8dir) && ln -sf mount.cifs.8 mount.smb3.8)
++      (cd $(DESTDIR)$(ROOTSBINDIR) && ln -sf mount.cifs mount.smb3)
 +      (cd $(DESTDIR)$(man8dir) && ln -sf mount.cifs.8 mount.smb3.8)
  
  uninstall-hook: