sci-libs/fftw: Fix usage of tc-getCC().
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Sun, 5 May 2019 02:46:00 +0000 (04:46 +0200)
committerMike Gilbert <floppym@gentoo.org>
Sun, 5 May 2019 19:04:02 +0000 (15:04 -0400)
Fixes: https://bugs.gentoo.org/618282
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
sci-libs/fftw/fftw-3.3.6_p2.ebuild
sci-libs/fftw/fftw-3.3.8.ebuild
sci-libs/fftw/fftw-9999.ebuild

index 35d91fe43ac0dc6da0d9cdd32a1ee362320969cb..4535c715b265504530cd009ad5a259e47805ec61 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -130,7 +130,7 @@ multilib_src_configure() {
                        ;;
        esac
 
-       ECONF_SOURCE="${S}" econf "${myconf[@]}" MPICC="$(tc-getCC -lmpi)"
+       ECONF_SOURCE="${S}" econf "${myconf[@]}" MPICC="$(tc-getCC) -lmpi"
 }
 
 src_configure() {
index d345f5d141f99a8349186a6dc6193f3f87ced493..c89038acc6aad7ce771f6722cf0830c58c23a816 100644 (file)
@@ -131,7 +131,7 @@ multilib_src_configure() {
                        ;;
        esac
 
-       ECONF_SOURCE="${S}" econf "${myconf[@]}" MPICC="$(tc-getCC -lmpi)"
+       ECONF_SOURCE="${S}" econf "${myconf[@]}" MPICC="$(tc-getCC) -lmpi"
 }
 
 src_configure() {
index c08278dde80122987ad1c0553c7a40d7e45038d5..a43b48e5809f7fa107a47d166aa0a1301aa52e01 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -138,7 +138,7 @@ multilib_src_configure() {
                MY_S="${BUILD_DIR}"
        fi
 
-       ECONF_SOURCE="${MY_S}" econf "${myconf[@]}" MPICC="$(tc-getCC -lmpi)"
+       ECONF_SOURCE="${MY_S}" econf "${myconf[@]}" MPICC="$(tc-getCC) -lmpi"
 }
 
 src_configure() {