dev-lang/go: remove 1.13.8
authorWilliam Hubbs <williamh@gentoo.org>
Sat, 4 Apr 2020 17:46:07 +0000 (12:46 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Sat, 4 Apr 2020 18:15:49 +0000 (13:15 -0500)
Signed-off-by: William Hubbs <williamh@gentoo.org>
dev-lang/go/Manifest
dev-lang/go/go-1.13.8.ebuild [deleted file]

index 6812f466f9e13c474277571f42f651544ba9cbc5..35ef4495821b259e725263a03b8b3a9c7608922d 100644 (file)
@@ -10,6 +10,5 @@ DIST go-linux-ppc64le-bootstrap-1.8.tbz 52211575 BLAKE2B 7a28ec5a381369c4e9415c8
 DIST go-linux-s390x-bootstrap-1.8.tbz 57124869 BLAKE2B 920a176b8f4fc3a816e724324bbb30a383d599e31a0d2093d24797dbcd0e799a662a3589dbb87d2f5dd16df07c4cf8f1e444e87b540ec732746bb025dc9271f8 SHA512 d429cae870d66217ab2e07c74209d3031d97baa4f899b4d70ae6283a1a5b1434b037904c4cfca0b2bc798d5ba0b358c3739e000eccbc74809baf564c5686df5a
 DIST go-solaris-amd64-bootstrap-1.8.tbz 54926326 BLAKE2B 0a45312f090d81ebf46fe5950cb65c059e2801394231e715e94145d1f918eb59b10472b2385e57ebd5cfb9eca0ad7290fb118436486b665520bb540970f971ab SHA512 52b849e5b9a940e10de7ba3df0ebdf6e1c5d631de9581d936c9edf8f38e6bb3314acbc2b2d5202b0528fde2a359d52bc0c6f39acf9b1b614725e4b4a947ed10d
 DIST go1.12.17.src.tar.gz 20725913 BLAKE2B 2eef7374195302656268a42409619445dfeb3ede1f9218ae4eab195916876b97f7510cc62585a0bfdd9f86dddf8a74000032a84b29bc9891d84fc69db94f0274 SHA512 069f8f445d9d2268ebb14b2446fab34843d56283c04561636d122fd8b4c1ea0b63640a84437db7a7be71039440ffe170cd3f8025b03b0acf95f2a56fa2febec6
-DIST go1.13.8.src.tar.gz 21631178 BLAKE2B 1752a4ecc4fd9409ebbb129f6b6edaacb7d9e140e3b0a8cbbb9b16b64b481a375b4fbe2a4814e2a272be4fdb5929e5d40f40778a07d6ff0b814230b2d4ed9697 SHA512 5df45c4701631e7a70f4f25b07ed00dc9a56bdebeb5ead2d04e0e6b000e8a9f00d193247e626ef5b1e6b7fc54bf27fbc5e8fb21b23ab52ec397f2238c5dfa000
 DIST go1.13.9.src.tar.gz 21700289 BLAKE2B 7c58dd89d164913dc85c8dc9e8b86798daad8bd58936b0ced21d3c084e0488306577273a6fa748bfee505fd38b90727a3cd9ab4ceebc1e62a0490b992cfa5bbe SHA512 0034ec394141e2c19941bf839cad93992c175476e3f3fa7b483c919aeea01fa4e0136eb8dd87a3158b911c04ded98a3c4960975a13280f1be076eb8f51464a98
 DIST go1.14.1.src.tar.gz 22451159 BLAKE2B 2b45716cdc82edb94609143bcbb79b313ff3b6b1cc9e0791236a8d968a2fc1d84015037a2cfb75e5b73dac4974b97a1e62f1fd1f5afe0dc633137b73ab15004a SHA512 f0112fbf984e2764cd90d42b2f844b986b421adf8bf68551cccefeb320db7f3490ab1532f770f20c943c68c7185ce139c8248991adb0529527358ffdc8047ad9
diff --git a/dev-lang/go/go-1.13.8.ebuild b/dev-lang/go/go-1.13.8.ebuild
deleted file mode 100644 (file)
index 8892f5c..0000000
+++ /dev/null
@@ -1,197 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-
-MY_PV=${PV/_/}
-
-inherit toolchain-funcs
-
-case ${PV}  in
-*9999*)
-       EGIT_REPO_URI="https://github.com/golang/go.git"
-       inherit git-r3
-       ;;
-*)
-       SRC_URI="https://storage.googleapis.com/golang/go${MY_PV}.src.tar.gz "
-       S="${WORKDIR}"/go
-       case ${PV} in
-       *_beta*|*_rc*) ;;
-       *)
-               KEYWORDS="-* amd64 arm arm64 ppc64 ~s390 x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
-               # The upstream tests fail under portage but pass if the build is
-               # run according to their documentation [1].
-               # I am restricting the tests on released versions until this is
-               # solved.
-               # [1] https://golang.org/issues/18442
-               RESTRICT="test"
-               ;;
-       esac
-esac
-
-DESCRIPTION="A concurrent garbage collected and typesafe programming language"
-HOMEPAGE="https://golang.org"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-
-BDEPEND="|| (
-               dev-lang/go
-               dev-lang/go-bootstrap )"
-RDEPEND="!<dev-go/go-tools-0_pre20150902"
-
-# These test data objects have writable/executable stacks.
-QA_EXECSTACK="
-       usr/lib/go/src/debug/elf/testdata/*.obj
-       usr/lib/go/src/*.gox
-       "
-
-# Do not complain about CFLAGS, etc, since Go doesn't use them.
-QA_FLAGS_IGNORED='.*'
-
-REQUIRES_EXCLUDE="/usr/lib/go/src/debug/elf/testdata/*"
-
-# The tools in /usr/lib/go should not cause the multilib-strict check to fail.
-QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/.*/.*"
-
-# Do not strip this package. Stripping is unsupported upstream and may
-# fail.
-RESTRICT+=" strip"
-
-DOCS=(
-AUTHORS
-CONTRIBUTING.md
-CONTRIBUTORS
-PATENTS
-README.md
-)
-
-go_arch()
-{
-       # By chance most portage arch names match Go
-       local portage_arch=$(tc-arch $@)
-       case "${portage_arch}" in
-               x86)    echo 386;;
-               x64-*)  echo amd64;;
-               ppc64) [[ $(tc-endian $@) = big ]] && echo ppc64 || echo ppc64le ;;
-               s390) echo s390x ;;
-               *)              echo "${portage_arch}";;
-       esac
-}
-
-go_arm()
-{
-       case "${1:-${CHOST}}" in
-               armv5*) echo 5;;
-               armv6*) echo 6;;
-               armv7*) echo 7;;
-               *)
-                       die "unknown GOARM for ${1:-${CHOST}}"
-                       ;;
-       esac
-}
-
-go_os()
-{
-       case "${1:-${CHOST}}" in
-               *-linux*)       echo linux;;
-               *-darwin*)      echo darwin;;
-               *-freebsd*)     echo freebsd;;
-               *-netbsd*)      echo netbsd;;
-               *-openbsd*)     echo openbsd;;
-               *-solaris*)     echo solaris;;
-               *-cygwin*|*-interix*|*-winnt*)
-                       echo windows
-                       ;;
-               *)
-                       die "unknown GOOS for ${1:-${CHOST}}"
-                       ;;
-       esac
-}
-
-go_tuple()
-{
-       echo "$(go_os $@)_$(go_arch $@)"
-}
-
-go_cross_compile()
-{
-       [[ $(go_tuple ${CBUILD}) != $(go_tuple) ]]
-}
-
-src_compile()
-{
-       if has_version -b dev-lang/go; then
-               export GOROOT_BOOTSTRAP="${BROOT}/usr/lib/go"
-       elif has_version -b dev-lang/go-bootstrap; then
-               export GOROOT_BOOTSTRAP="${BROOT}/usr/lib/go-bootstrap"
-       else
-               eerror "Go cannot be built without go or go-bootstrap installed"
-               die "Should not be here, please report a bug"
-       fi
-
-       export GOROOT_FINAL="${EPREFIX}"/usr/lib/go
-       export GOROOT="$(pwd)"
-       export GOBIN="${GOROOT}/bin"
-
-       # Go's build script does not use BUILD/HOST/TARGET consistently. :(
-       export GOHOSTARCH=$(go_arch ${CBUILD})
-       export GOHOSTOS=$(go_os ${CBUILD})
-       export CC=$(tc-getBUILD_CC)
-
-       export GOARCH=$(go_arch)
-       export GOOS=$(go_os)
-       export CC_FOR_TARGET=$(tc-getCC)
-       export CXX_FOR_TARGET=$(tc-getCXX)
-       if [[ ${ARCH} == arm ]]; then
-               export GOARM=$(go_arm)
-       fi
-
-       cd src
-       ./make.bash || die "build failed"
-}
-
-src_test()
-{
-       go_cross_compile && return 0
-
-       cd src
-       PATH="${GOBIN}:${PATH}" \
-       ./run.bash -no-rebuild || die "tests failed"
-}
-
-src_install()
-{
-       local bin_path f x
-
-       dodir /usr/lib/go
-
-       # There is a known issue which requires the source tree to be installed [1].
-       # Once this is fixed, we can consider using the doc use flag to control
-       # installing the doc and src directories.
-       # [1] https://golang.org/issue/2775
-       #
-       # deliberately use cp to retain permissions
-       cp -R api bin doc lib pkg misc src test "${ED}"/usr/lib/go
-       if go_cross_compile; then
-               bin_path="bin/$(go_tuple)"
-       else
-               bin_path=bin
-       fi
-       for x in ${bin_path}/*; do
-               f=${x##*/}
-               dosym ../lib/go/${bin_path}/${f} /usr/bin/${f}
-       done
-       einstalldocs
-
-       if [[ ${CHOST} == *-darwin* ]] ; then
-               # fix install_name for test object (binutils_test) on Darwin, it
-               # is never used in real circumstances
-               local libmac64="${EPREFIX}"/usr/lib/go/src/cmd/vendor/github.com/
-                     libmac64+=google/pprof/internal/binutils/testdata/lib_mac_64
-               install_name_tool -id "${libmac64}" "${D}${libmac64}"
-       fi
-}