media-libs/libhdhomerun: Bump to version 20190621
authorWilson Michaels <thebitpit@eartlink.net>
Fri, 13 Sep 2019 18:08:15 +0000 (13:08 -0500)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Sep 2019 17:57:06 +0000 (19:57 +0200)
Upgrade to EAPI 7

Package-Manager: Portage-2.3.69, Repoman-2.3.16
Closes: https://bugs.gentoo.org/676140
Signed-off-by: Wilson Michaels <thebitpit@eartlink.net>
Closes: https://github.com/gentoo/gentoo/pull/12922
Signed-off-by: Michał Górny <mgorny@gentoo.org>
media-libs/libhdhomerun/Manifest
media-libs/libhdhomerun/files/20190621-use_shared_library.patch [new file with mode: 0644]
media-libs/libhdhomerun/libhdhomerun-20190621.ebuild [new file with mode: 0644]
media-libs/libhdhomerun/metadata.xml

index f20c74511bc88437b05cdff5fb889e8a5ac0b50c..0102edf01530015830f131cfd504f6c7db1514c2 100644 (file)
@@ -1 +1,2 @@
 DIST libhdhomerun_20150826.tgz 49169 BLAKE2B 6b780d61624e9cca9ca6afbbcdf91377dc134782ee22752c8d92849c6eabac502a3a8a8659035b8a0fd66ae1d7404f6696f78758e0ff4484b46b84ca7282b48f SHA512 9b401c1649dc8c32ea9019b732631f9213cb66c43771aa148fa318202fc11739c005c474be6a77a6a7807818b5179f77debb5b2d2411d865cc87bb3d7ab629a6
+DIST libhdhomerun_20190621.tgz 50817 BLAKE2B 7d4293e38be5283fba5d46cb162ee19d90c30ed63481cd94445a055fa0f80597fdacedd59e35ba4edfb53934ce339e967eb0c42d0ae72289ce7d39eb1f91cd50 SHA512 d15c5b0703bf8ca1f3979a8cad93fc33d87c1309367ad5117354c60112a5505d90e80d4bf9055d16b0eef2b892015c5f4886e6544178090b3550c3a8dbd86576
diff --git a/media-libs/libhdhomerun/files/20190621-use_shared_library.patch b/media-libs/libhdhomerun/files/20190621-use_shared_library.patch
new file mode 100644 (file)
index 0000000..a25b334
--- /dev/null
@@ -0,0 +1,16 @@
+--- /Makefile  2019-09-16 10:18:56.033121543 -0500
++++ /Makefile  2019-09-16 10:14:00.110155153 -0500
+@@ -38,10 +38,10 @@
+   endif
+ endif
+-all : hdhomerun_config$(BINEXT) libhdhomerun$(LIBEXT)
++all : libhdhomerun$(LIBEXT) hdhomerun_config$(BINEXT)
+-hdhomerun_config$(BINEXT) : hdhomerun_config.c $(LIBSRCS)
+-      $(CC) $(CFLAGS) $+ $(LDFLAGS) -o $@
++hdhomerun_config$(BINEXT) : hdhomerun_config.c libhdhomerun$(LIBEXT)
++      $(CC) $(CFLAGS) $+ $(LDFLAGS) -L./ -lhdhomerun -o $@
+       $(STRIP) $@
+ libhdhomerun$(LIBEXT) : $(LIBSRCS)
diff --git a/media-libs/libhdhomerun/libhdhomerun-20190621.ebuild b/media-libs/libhdhomerun/libhdhomerun-20190621.ebuild
new file mode 100644 (file)
index 0000000..6ce4daf
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="SiliconDust HDHomeRun Utilties"
+HOMEPAGE="https://www.silicondust.com/support/linux/"
+SRC_URI="https://download.silicondust.com/hdhomerun/${PN}_${PV}.tgz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+       "${FILESDIR}/${PV}-use_shared_library.patch"
+)
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+       default
+       #Remove forced optimization from Makefile
+       sed -i 's:-O2::' Makefile || die "Was the Makefile changed?"
+}
+
+src_compile() {
+       emake CC=$(tc-getCC) STRIP=:
+}
+
+src_install() {
+       dobin hdhomerun_config
+       dolib.so libhdhomerun.so
+
+       insinto /usr/include/hdhomerun
+       doins *.h
+}
index 6f49eba8f49693023f393161560b3a2d9e2717c5..4c0ca2be0ca6d330534cde5c3b02e0254261f8e7 100644 (file)
@@ -1,5 +1,12 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<!-- maintainer-needed -->
+       <maintainer type="person">
+               <email>thebitpit@earthlink.net</email>
+               <name>Wilson Michaels</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
 </pkgmetadata>