dev-python/bottle: Remove old
authorMichał Górny <mgorny@gentoo.org>
Tue, 11 Feb 2020 11:19:21 +0000 (12:19 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 11 Feb 2020 11:37:53 +0000 (12:37 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/bottle/Manifest
dev-python/bottle/bottle-0.12.16.ebuild [deleted file]

index b045cc6bb2e8696f92f6af8db2047b95db8af41f..f8636ed54391e095a3e1396949f395484bc92633 100644 (file)
@@ -1,2 +1 @@
-DIST bottle-0.12.16.tar.gz 72248 BLAKE2B 21b5bc376648baec74577ac5b57fcacc58899babe07a034a436d5e2bde75a9e2e48b2569c5caf1478e77790c5fa327114ab9b084f014cc1ba97637d9ddfec659 SHA512 3c167f95902522c8f264e8478403da8e9b8cd84594318c4a773d38b7548b5ba95c99ef922033f6885cdc044b31f9c2e2f7ed263886637ce2a048e99c0c6e1403
 DIST bottle-0.12.18.tar.gz 71557 BLAKE2B a34cc1ab9a2a8505b7fda8bbddbae30b4e6c4829cae53f0f886237a21fdfa7f2b2463b216d7a16464539f41bdce4c1dabb5cc66027b8fdd19b10e9a78a3cdbb5 SHA512 db8a341cd80d755205518bb9eac5b79dca9e541ab3ad9d9d57f891d895f7df75a8facd16b068cbdf7c4f884f35e384449f4cbd565a43e9c5d000d3a9f5b7dcb0
diff --git a/dev-python/bottle/bottle-0.12.16.ebuild b/dev-python/bottle/bottle-0.12.16.ebuild
deleted file mode 100644 (file)
index 41250b4..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="A fast and simple micro-framework for small web-applications"
-HOMEPAGE="https://pypi.org/project/bottle/ https://bottlepy.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               $(python_gen_cond_dep '
-                       dev-python/mako[${PYTHON_USEDEP}]
-               ' 'python*')
-       )"
-RDEPEND=""
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-0.12.8-py3.5-backport.patch
-)
-
-python_prepare_all() {
-       sed -i -e '/scripts/d' setup.py || die
-
-       # Remove test file requring connection to network
-       rm test/test_server.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       # A few odd fails in the suite under pypy
-       # https://github.com/bottlepy/bottle/issues/714
-       "${EPYTHON}" test/testall.py || die "tests failed under ${EPYTHON}"
-}
-
-pkg_postinst() {
-       optfeature "Templating support" dev-python/mako
-       elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
-       elog "we do as most other distros and do not install the script anymore."
-       elog "If you do want/have to call it directly rather than through your app,"
-       elog "please use the following instead:"
-       elog '  `python -m bottle`'
-}