www-client/uget: Migrate to 'appindicator' USE
authorPacho Ramos <pacho@gentoo.org>
Fri, 1 May 2020 17:51:45 +0000 (19:51 +0200)
committerPacho Ramos <pacho@gentoo.org>
Fri, 1 May 2020 17:57:32 +0000 (19:57 +0200)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
www-client/uget/uget-2.2.0.ebuild
www-client/uget/uget-2.2.1.ebuild
www-client/uget/uget-9999.ebuild

index bdc8c19e2f0f402db65dc61c5bc659bd40658882..94ef4493b3bbad99e702f6877c58e6dbfca936db 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/urlget/${P}.tar.gz"
 LICENSE="LGPL-2.1"
 SLOT="0"
 KEYWORDS="amd64 ~arm ~ppc x86"
-IUSE="aria2 ayatana control-socket +gnutls gstreamer libnotify nls openssl rss"
+IUSE="aria2 appindicator control-socket +gnutls gstreamer libnotify nls openssl rss"
 REQUIRED_USE="^^ ( gnutls openssl )"
 
 RDEPEND="
@@ -25,7 +25,7 @@ RDEPEND="
                dev-libs/libgcrypt:0
        )
        aria2? ( net-misc/aria2[xmlrpc] )
-       ayatana? ( dev-libs/libappindicator:3 )
+       appindicator? ( dev-libs/libappindicator:3 )
        gstreamer? ( media-libs/gstreamer:1.0 )
        libnotify? ( x11-libs/libnotify )
        openssl? ( dev-libs/openssl:0 )
@@ -38,7 +38,7 @@ DEPEND="${RDEPEND}
 
 src_configure() {
        local myconf=(
-               $(use_enable ayatana appindicator)
+               $(use_enable appindicator)
                $(use_enable control-socket unix_socket)
                $(use_enable gstreamer)
                $(use_enable libnotify notify)
index 1a5a0ce8eda34b606b327988e9fd1ca6200bee82..3608bf8baca1b9c5040005d4ea06c0f66550096e 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/urlget/${P}.tar.gz"
 LICENSE="LGPL-2.1"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~ppc ~x86"
-IUSE="aria2 ayatana control-socket +gnutls gstreamer libnotify nls openssl rss"
+IUSE="aria2 appindicator control-socket +gnutls gstreamer libnotify nls openssl rss"
 REQUIRED_USE="^^ ( gnutls openssl )"
 
 RDEPEND="
@@ -25,7 +25,7 @@ RDEPEND="
                dev-libs/libgcrypt:0
        )
        aria2? ( net-misc/aria2[xmlrpc] )
-       ayatana? ( dev-libs/libappindicator:3 )
+       appindicator? ( dev-libs/libappindicator:3 )
        gstreamer? ( media-libs/gstreamer:1.0 )
        libnotify? ( x11-libs/libnotify )
        openssl? ( dev-libs/openssl:0 )
@@ -38,7 +38,7 @@ DEPEND="${RDEPEND}
 
 src_configure() {
        local myconf=(
-               $(use_enable ayatana appindicator)
+               $(use_enable appindicator)
                $(use_enable control-socket unix_socket)
                $(use_enable gstreamer)
                $(use_enable libnotify notify)
index 602b282b09d6b9d2a148efed8e453ef909e8b121..a713a776b8932be0472073f4da1f5994c2023a07 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -13,7 +13,7 @@ EGIT_REPO_URI="git://git.code.sf.net/p/urlget/uget2"
 LICENSE="LGPL-2.1"
 SLOT="0"
 KEYWORDS=""
-IUSE="aria2 ayatana control-socket +gnutls gstreamer libnotify nls openssl rss"
+IUSE="aria2 appindicator control-socket +gnutls gstreamer libnotify nls openssl rss"
 
 RDEPEND="
        >=net-misc/curl-7.19.1
@@ -25,7 +25,7 @@ RDEPEND="
                dev-libs/libgcrypt:0
        )
        aria2? ( net-misc/aria2[xmlrpc] )
-       ayatana? ( dev-libs/libappindicator:3 )
+       appindicator? ( dev-libs/libappindicator:3 )
        gstreamer? ( media-libs/gstreamer:1.0 )
        libnotify? ( x11-libs/libnotify )
        "
@@ -42,7 +42,7 @@ src_prepare() {
 
 src_configure() {
        local myconf=(
-               $(use_enable ayatana appindicator)
+               $(use_enable appindicator)
                $(use_enable control-socket unix_socket)
                $(use_enable gstreamer)
                $(use_enable libnotify notify)