Removed obsolete ebuilds and finally got rid of the tcltk flag in R-2.2.1 (see bug...
authorMarkus Dittrich <markusle@gentoo.org>
Sat, 13 Jan 2007 15:45:51 +0000 (15:45 +0000)
committerMarkus Dittrich <markusle@gentoo.org>
Sat, 13 Jan 2007 15:45:51 +0000 (15:45 +0000)
Package-Manager: portage-2.1.2_rc4-r7

dev-lang/R/ChangeLog
dev-lang/R/R-2.2.1.ebuild

index 06bd7f2cfd0b055e950a3c18a37ae0cff50356d5..e4301c66c9dd5859b935af6a8b915b40ae141d0e 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-lang/R
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.81 2006/12/19 04:17:40 markusle Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.82 2007/01/13 15:45:51 markusle Exp $
+
+  13 Jan 2007; Markus Dittrich <markusle@gentoo.org> -R-2.1.1.ebuild,
+  -R-2.2.0-r1.ebuild, R-2.2.1.ebuild, -R-2.3.0.ebuild, -R-2.3.1.ebuild,
+  -R-2.4.0.ebuild:
+  Removed obsolete ebuilds and finally got rid of the tcltk flag
+  in R-2.2.1 (see bug #17808).
 
 *R-2.4.1 (19 Dec 2006)
 
index a8588fc390863c75606eda4b4938317760d16f7e..8af0deb0b4657048251686d7f80ff3e8c7c04ab5 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.2.1.ebuild,v 1.13 2006/08/07 12:51:34 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.2.1.ebuild,v 1.14 2007/01/13 15:45:51 markusle Exp $
 
 inherit fortran toolchain-funcs flag-o-matic
 
@@ -11,7 +11,7 @@ SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz"
 LICENSE="GPL-2 LGPL-2.1"
 SLOT="0"
 KEYWORDS="amd64 ia64 ppc ppc64 sparc x86"
-IUSE="blas jpeg nls png readline tcltk X lapack"
+IUSE="blas jpeg nls png readline tk X lapack"
 
 RDEPEND=">=dev-lang/perl-5.6.1-r3
        readline? ( >=sys-libs/readline-4.1-r3 )
@@ -19,7 +19,8 @@ RDEPEND=">=dev-lang/perl-5.6.1-r3
        png? ( >=media-libs/libpng-1.2.1 )
        blas? ( virtual/blas )
        lapack? ( virtual/lapack )
-       tcltk? ( dev-lang/tk )
+       tk? ( dev-lang/tk
+               dev-lang/tcl )
        X? ( || ( ( x11-libs/libX11 )
                virtual/x11 ) )"
 DEPEND="${RDEPEND}
@@ -51,7 +52,7 @@ pkg_setup() {
 src_compile() {
        local myconf="--enable-R-profiling --enable-R-shlib --enable-linux-lfs"
 
-       if use tcltk; then
+       if use tk; then
                #configure needs to find the files tclConfig.sh and tkConfig.sh
                myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib/tclConfig.sh
                        --with-tk-config=/usr/lib/tkConfig.sh"