dev-python/pycxx: Replace distutils-r1 EXAMPLES use
authorDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 09:57:00 +0000 (10:57 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 09:57:00 +0000 (10:57 +0100)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/pycxx/pycxx-6.2.6.ebuild
dev-python/pycxx/pycxx-7.1.2.ebuild

index c90dbab688d32981318287d6821d93b08c18d973..1baa0be8acc3e47c82bd9ea909ff55e21f52089d 100644 (file)
@@ -31,6 +31,11 @@ python_prepare_all() {
 
 python_install_all() {
        use doc && local HTML_DOCS=( Doc/. )
-       use examples && local EXAMPLES=( Demo/Python{2,3}/. )
+       if use examples; then
+               docinto examples
+               dodoc -r Demo/Python{2,3}/.
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+
        distutils-r1_python_install_all
 }
index d9581f73d9f4af86065db2f236256339d0c6a975..9e61adbe736c82405bd1a0dfb99ef09a0f806c2a 100644 (file)
@@ -25,6 +25,11 @@ python_prepare_all() {
 
 python_install_all() {
        use doc && local HTML_DOCS=( Doc/. )
-       use examples && local EXAMPLES=( Demo/Python{2,3}/. )
+       if use examples; then
+               docinto examples
+               dodoc -r Demo/Python{2,3}/.
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+
        distutils-r1_python_install_all
 }