app-crypt/keynote: Remove last-rited pkg
authorMichał Górny <mgorny@gentoo.org>
Sat, 20 Apr 2019 08:19:17 +0000 (10:19 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 20 Apr 2019 08:19:56 +0000 (10:19 +0200)
Closes: https://bugs.gentoo.org/675010
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-crypt/keynote/Manifest [deleted file]
app-crypt/keynote/files/keynote-2.3-parallel-build.patch [deleted file]
app-crypt/keynote/files/keynote-2.3-qa.patch [deleted file]
app-crypt/keynote/keynote-2.3-r3.ebuild [deleted file]
app-crypt/keynote/metadata.xml [deleted file]
profiles/package.mask

diff --git a/app-crypt/keynote/Manifest b/app-crypt/keynote/Manifest
deleted file mode 100644 (file)
index 555feb1..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST keynote-2.3.tar.gz 141930 BLAKE2B 9cbf18214ca8d39a09be149370b104989470d8040ea307b263451d0d0c74f4658f4620ac16d8f2a5310edca78555e6b8077d67c96941722cd0bc8afa923a2452 SHA512 c4f2f70718cf6092a9af82d6f6e1d8e24d03be9a938e2bde830b24794cd20610b8f647c552d46e37e840f1a1a432dc797b65548c4d39cdbaa65ec2d11f6cfefe
diff --git a/app-crypt/keynote/files/keynote-2.3-parallel-build.patch b/app-crypt/keynote/files/keynote-2.3-parallel-build.patch
deleted file mode 100644 (file)
index cf4b492..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- keynote-2.3.orig/Makefile.in       2010-02-04 09:51:35.757096194 +0100
-+++ keynote-2.3/Makefile.in    2010-02-04 09:52:17.441137132 +0100
-@@ -86,9 +86,11 @@
- k.tab.c: keynote.y header.h keynote.h assertion.h config.h
-       $(YACC) $(YACCFLAGS) keynote.y
-+k.tab.h: k.tab.c
- z.tab.c: keynote-ver.y keynote.h header.h config.h
-       $(YACC) $(YACCFLAGS2) keynote-ver.y
-+z.tab.h: z.tab.c
- lex.kn.c: keynote.l k.tab.h header.h keynote.h assertion.h config.h
-       $(LEX) $(LEXFLAGS) keynote.l
diff --git a/app-crypt/keynote/files/keynote-2.3-qa.patch b/app-crypt/keynote/files/keynote-2.3-qa.patch
deleted file mode 100644 (file)
index f6b1ff2..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-Respect CFLAGS, LDFLAGS, and AR.
-
-The better way to fix AR would be to patch configure.in,
-but it is sufficiently old to fail with current autotools.
---- Makefile.in
-+++ Makefile.in
-@@ -27,7 +27,6 @@
- YACC = @YACC@
- SSLEAY = @SSLEAY@
- RM = @RM@
--AR = @AR@
- NROFF = @NROFF@
- TAR = @TAR@
- TRUE = @TRUE@
-@@ -41,10 +40,10 @@
- YACCFLAGS = -d -p kn -b k
- LEXFLAGS2 = -Pkv -s -i
- LEXFLAGS = -Cr -Pkn -s -i
--CFLAGS = -O2 -Wall # -g
- RMFLAGS2 = -rf
- RMFLAGS = -f
- NROFFFLAGS = -mandoc
-+LDFLAGS = @LDFLAGS@
- SSLCONF = testsuite/openssl.cnf
- SSLCERT = testsuite/test.cert.pem
-@@ -83,7 +82,7 @@
-       $(RANLIB) $(TARGET)
- $(TARGET2): $(TARGET) $(OBJS2)
--      $(CC) $(CFLAGS) -o $(TARGET2) $(OBJS2) $(LIBS)
-+      $(CC) $(CFLAGS) $(LDFLAGS) -o $(TARGET2) $(OBJS2) $(LIBS)
- k.tab.c: keynote.y header.h keynote.h assertion.h config.h
-       $(YACC) $(YACCFLAGS) keynote.y
-@@ -131,7 +130,7 @@
-       -keyout $(SSLKEY)
- test-sample: all $(OBJS3)
--      $(CC) $(CFLAGS) -o $(TARGET3) $(OBJS3) $(LIBS)
-+      $(CC) $(CFLAGS) $(LDFLAGS) -o $(TARGET3) $(OBJS3) $(LIBS)
- test-sig: all $(SSLCERT) $(SSLKEY)
-       $(SED) -e 's/--.*//' < $(SSLCERT) > $(SSLCERT).1
diff --git a/app-crypt/keynote/keynote-2.3-r3.ebuild b/app-crypt/keynote/keynote-2.3-r3.ebuild
deleted file mode 100644 (file)
index b4351b6..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="The KeyNote Trust-Management System"
-HOMEPAGE="http://www1.cs.columbia.edu/~angelos/keynote.html"
-SRC_URI="http://www1.cs.columbia.edu/~angelos/Code/${P}.tar.gz"
-
-LICENSE="keynote"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="libressl ssl"
-
-RDEPEND="ssl? (
-               !libressl? ( dev-libs/openssl:0= )
-               libressl? ( dev-libs/libressl:0= )
-       )"
-DEPEND="${RDEPEND}
-       virtual/yacc"
-
-pkg_setup() {
-       tc-export AR CC RANLIB
-       # bug #448904
-       export ac_cv_path_AR="$(type -p $(tc-getAR))"
-}
-
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-qa.patch
-       epatch "${FILESDIR}"/${P}-parallel-build.patch
-}
-
-src_compile() {
-       if use ssl; then
-               emake
-       else
-               emake nocrypto
-       fi
-}
-
-src_install() {
-       dobin keynote
-
-       dolib.a libkeynote.a
-
-       insinto /usr/include
-       doins keynote.h
-
-       doman man/keynote.[1345]
-       dodoc README HOWTO.add.crypto TODO
-}
diff --git a/app-crypt/keynote/metadata.xml b/app-crypt/keynote/metadata.xml
deleted file mode 100644 (file)
index 6f49eba..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-</pkgmetadata>
index e2dd06224662dc3cdaa491e742815a9bcb0fd5ce..122ddc9807fab850800fae4ea16243d1f8569c4d 100644 (file)
@@ -601,15 +601,6 @@ dev-libs/libmcal
 # Removal in 30 days.  Bug #676190.
 x11-libs/hippo-canvas
 
-# Michał Górny <mgorny@gentoo.org> (21 Mar 2019)
-# The following packages are unmaintained and fail to build against
-# openssl-1.1+.
-#
-# app-crypt/keynote: #675010, last updated upstream in 2000
-#
-# Removal in 30 days.
-app-crypt/keynote
-
 # Miroslav Šulc <fordfrog@gentoo.org> (19 Mar 2019)
 # Depends on >=virtual/{jdk,jre}-11 which is masked
 =www-servers/tomcat-9.0.17