dev-python/openpyxl: bump v3.0.0 (Python3 only)
authorZamarin Arthur <arthurzam@gmail.com>
Fri, 18 Oct 2019 18:25:21 +0000 (21:25 +0300)
committerMichał Górny <mgorny@gentoo.org>
Sat, 9 Nov 2019 17:23:44 +0000 (18:23 +0100)
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Zamarin Arthur <arthurzam@gmail.com>
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/openpyxl/Manifest
dev-python/openpyxl/openpyxl-3.0.0.ebuild [new file with mode: 0644]

index fa549c6beb9e7c6e0db8aafba1338d2be6c7e1e2..eaf2055433f74f7d39f64ef1ea520c928f2f0384 100644 (file)
@@ -1,3 +1,4 @@
 DIST openpyxl-2.6.1.tar.bz2 2403827 BLAKE2B 26abdea047b4d283f3d0e3ed499c1d7247d07b7a97426fd681d92798c7c49cc13fd53296e214d2c48e8461a80740a5ae600468bcf41c9cfd5b6f0b244ef3df93 SHA512 cf869b20ae8aeb068139eaddc8c915ba15405d531bc1a6e2b7c8068bad0ca628622c852cc1d4e11dfd8fab0078a9931fc33e5e47bda954b7cc994f60d79753fc
 DIST openpyxl-2.6.2.tar.bz2 2404387 BLAKE2B ce63ed51bc2f475fc12f510307e3cd417321588aa1a9adb5f8b780249898747babf211137d21442eceaff01bcfb4f7b8f3092b3dc64f751aa2b26d404d11fb74 SHA512 e037abd13e050e25146b016c578bb50c008b7c74a19702d9bae14b594ad5f30d352f8443fd5021a169991a96f5d19b84a3acceb9b05a713e8526ad478fffd31f
 DIST openpyxl-2.6.4.tar.bz2 2406293 BLAKE2B 5395820c2b7a1c6f754f80d33f629b438cbf6421b91d8f3c0a3cd4b4105b84f1b4b90ec1a5557193924718e462af1720c166fc37295ebd0c3b0c270f4cd7af7a SHA512 0880c61b2f2fe6162a1aaa6815607ca20cadac3e58a92f737bc4c7a5a867a0d731ea3ad144d552fb2854b703b7426f1c8c3b3d8ea6c64ab2485f9733f0fabc61
+DIST openpyxl-3.0.0.tar.bz2 2405154 BLAKE2B d14e529c73cebd3eab6a4d93dc38c1807d38a5396032b4df77bc7af5d98b5b68369f1b44cce83d77592e7aca673ca497d49a1fafc1f0bcca3c0aff19486ea8db SHA512 fc0c31b1ae486f6fc8802dbd6ea2efee65e788b452240985202617109113dfccb5b26bfa94c2ac42a0ac218ff75bc310773f96122da1522537c063e8d55309f4
diff --git a/dev-python/openpyxl/openpyxl-3.0.0.ebuild b/dev-python/openpyxl/openpyxl-3.0.0.ebuild
new file mode 100644 (file)
index 0000000..b29ebbc
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Pure python reader and writer of Excel OpenXML files"
+HOMEPAGE="https://openpyxl.readthedocs.io/en/stable/"
+# Upstream doesn't want to include tests in PyPI tarballs
+# https://bitbucket.org/openpyxl/openpyxl/issues/1308/include-tests-in-pypi-tarballs
+SRC_URI="https://bitbucket.org/${PN}/${PN}/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-python/jdcal[${PYTHON_USEDEP}]
+       dev-python/et_xmlfile[${PYTHON_USEDEP}]
+"
+DEPEND="
+       test? (
+               ${RDEPEND}
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/lxml[${PYTHON_USEDEP}]
+               dev-python/pillow[${PYTHON_USEDEP},tiff,jpeg]
+       )"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+       pytest -vv || die "Testing failed with ${EPYTHON}"
+}