dev-python/sphinx-testing: Clean py2 deps up
authorMichał Górny <mgorny@gentoo.org>
Tue, 17 Mar 2020 07:38:58 +0000 (08:38 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 17 Mar 2020 08:07:41 +0000 (09:07 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/sphinx-testing/sphinx-testing-0.7.2.ebuild
dev-python/sphinx-testing/sphinx-testing-1.0.1-r1.ebuild
dev-python/sphinx-testing/sphinx-testing-1.0.1.ebuild

index b6913ffde4a5c156c1fc64da7c1e77629b07f748..b70328a430ff119968ceff61033e88295367bc2e 100644 (file)
@@ -20,8 +20,7 @@ RDEPEND="dev-python/six[${PYTHON_USEDEP}]
        dev-python/sphinx[${PYTHON_USEDEP}]"
 
 DEPEND="${RDEPEND}
-       test? ( dev-python/nose[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*') )"
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
 
 python_test() {
        nosetests || die
index 3114100fd698480b45f96eda95778cf3034b6e14..7b5554b2e1ef180dc6549092f043b0c6b2be78c1 100644 (file)
@@ -23,7 +23,6 @@ DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                dev-python/nose[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
        )"
 
 python_test() {
index a9376463d9e75c2147a5fe622b23fe35dc6ea6f4..f8f4f5dc70af0afa69f8341d2ce03a74db2a2fdb 100644 (file)
@@ -23,7 +23,6 @@ DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                dev-python/nose[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
        )"
 
 python_test() {