dev-libs/crypto++: USE cpu_flags_x86_sha->preview-cpu_flags_x86_sha
authorAlon Bar-Lev <alonbl@gentoo.org>
Mon, 8 Jul 2019 13:21:25 +0000 (16:21 +0300)
committerAlon Bar-Lev <alonbl@gentoo.org>
Mon, 8 Jul 2019 13:31:14 +0000 (16:31 +0300)
A temporary solution until cpu_flags_x86_sha available.

Closes: https://bugs.gentoo.org/show_bug.cgi?id=689476
Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

dev-libs/crypto++/crypto++-8.2.0-r2.ebuild
dev-libs/crypto++/metadata.xml

index 41b85ded0216396a555083a05bfd0de4a7e300bb..77fc17f4d982037bf8a3bf0eea4b880c0f8b170b 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI="https://www.cryptopp.com/cryptopp${PV//.}.zip"
 LICENSE="Boost-1.0"
 SLOT="0/8" # subslot is so version
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
-IUSE="+asm cpu_flags_x86_aes cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_pclmul cpu_flags_x86_sha cpu_flags_x86_sse2 cpu_flags_x86_sse4_2 cpu_flags_x86_ssse3 static-libs"
+IUSE="+asm cpu_flags_x86_aes cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_pclmul preview-cpu_flags_x86_sha cpu_flags_x86_sse2 cpu_flags_x86_sse4_2 cpu_flags_x86_ssse3 static-libs"
 
 BDEPEND="app-arch/unzip"
 
@@ -40,7 +40,7 @@ src_prepare() {
        use cpu_flags_x86_avx || config_add CRYPTOPP_DISABLE_AVX
        use cpu_flags_x86_avx2 || config_add CRYPTOPP_DISABLE_AVX2
        use cpu_flags_x86_pclmul || config_add CRYPTOPP_DISABLE_CLMUL
-       use cpu_flags_x86_sha || config_add CRYPTOPP_DISABLE_SHANI
+       use preview-cpu_flags_x86_sha || config_add CRYPTOPP_DISABLE_SHANI
        use cpu_flags_x86_sse2 || config_add CRYPTOPP_DISABLE_SSE2
        use cpu_flags_x86_sse4_2 || config_add CRYPTOPP_DISABLE_SSE4
        use cpu_flags_x86_ssse3 || config_add CRYPTOPP_DISABLE_SSSE3
index 4ceb05b8abe2763ca5da8aaa29f7e83c24181ff6..f2183896644902fa41679f7d8977d3ed167ec2f4 100644 (file)
@@ -11,7 +11,7 @@
        </maintainer>
        <use>
                <flag name="asm">Support assembly hand optimized crypto functions (i.e. faster run time)</flag>
-               <flag name="cpu_flags_x86_sha">Enable support for Intel's SHA instruction set (SHA-NI)</flag>
+               <flag name="preview-cpu_flags_x86_sha">Enable support for Intel's SHA instruction set (SHA-NI)</flag>
        </use>
        <upstream>
                <remote-id type="github">weidai11/cryptopp</remote-id>