app-admin/augeas: 1.11.0 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Fri, 24 Aug 2018 20:50:40 +0000 (15:50 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Fri, 24 Aug 2018 20:51:12 +0000 (15:51 -0500)
Package-Manager: Portage-2.3.48, Repoman-2.3.10

app-admin/augeas/Manifest
app-admin/augeas/augeas-1.11.0.ebuild [new file with mode: 0644]

index b0b19be4e507c5b45bf6fa67933c157bb28aa7ce..d7042a910b3ab99805a8d16a5f380e07ee39e60d 100644 (file)
@@ -1,2 +1,3 @@
 DIST augeas-1.10.1.tar.gz 2289207 BLAKE2B 6e3cf750c4d3faf7dc472ec7bfe3c46f5babca294d2bd5169cca419c2f93e21bdd656bbc44b30ab66c00fb793df1aa045f60c1260963901773c334b9019eff0b SHA512 382e8ef6a5bd3d12d7d2e0d2987f39c04ff7df3f07cd68aa732bf266b89d5d59a85be63921a7ff70f9219dbc6bb8547f80528242caa9417e08a008d1721cb1d2
+DIST augeas-1.11.0.tar.gz 2393675 BLAKE2B e7c50715fee892b47843f9be4ec9e88937c0ce10544b3e212d9c32a6151bbc36550d711ebec9db2a691e91cc6a2cd93696d807b440ab57a678ca6680426a4b03 SHA512 1b67bb7fcd9b560d3fe4a5c753d5e778db73caaab6e50367afd123eec107b65b73096913ac7d5170e85f5b63ff3522b2a6932b130e207ab22560dfc6e267b8a1
 DIST augeas-1.8.1.tar.gz 2165325 BLAKE2B aa309984b5b11441fd2b10f3dc0b4a5f79a39038c1a71af6f7ef68b4fc24074db0bbcfd97341828211cc63d60d4b814515b119d0305367e9594cd5aa5159b822 SHA512 80be6dc75e86e2a00c56cb668824ffbe54105b64fad64a2737d980c8ee5ba347a97ddd190a1c712bd07a768ed23a8d07b0eb676033b367632036a8e7f98c976b
diff --git a/app-admin/augeas/augeas-1.11.0.ebuild b/app-admin/augeas/augeas-1.11.0.ebuild
new file mode 100644 (file)
index 0000000..3ea24d3
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A library for changing configuration files"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="http://download.augeas.net/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs test"
+
+RDEPEND="
+       dev-libs/libxml2
+       sys-libs/readline:="
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       >=app-doc/NaturalDocs-1.40
+       test? ( dev-lang/ruby )"
+
+PATCHES=(
+)
+
+src_prepare() {
+       if [ -f /usr/share/NaturalDocs/Config/Languages.txt ] ; then
+               addwrite /usr/share/NaturalDocs/Config/Languages.txt
+       fi
+       if [ -f /usr/share/NaturalDocs/Config/Topics.txt ] ; then
+               addwrite /usr/share/NaturalDocs/Config/Topics.txt
+       fi
+       default
+}
+
+src_configure() {
+       # Needs to implemented
+       local myeconfargs="--without-selinux
+       $(use_enable !static-libs shared)
+       $(use_enable static-libs static)"
+       eautoreconf
+       econf ${myeconfargs}
+       default
+}