sys-kernel/vanilla-kernel: Revert "Bump to 5.4.10, use kernel-build.eclass"
authorMichał Górny <mgorny@gentoo.org>
Thu, 9 Jan 2020 20:59:29 +0000 (21:59 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 9 Jan 2020 21:00:08 +0000 (22:00 +0100)
Reverts: 6de9c4526dc8d29f2480f7080aa0a62e1c61f2cc
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-kernel/vanilla-kernel/Manifest
sys-kernel/vanilla-kernel/vanilla-kernel-5.4.10.ebuild [deleted file]

index 26dcb4ed4d0c50ca730ee68b0e1628f7e5966312..0e5750feae1919ae1f5a87130d67ebd2d3e4eaac 100644 (file)
@@ -1,4 +1,3 @@
-DIST linux-5.4.10.tar.xz 109453652 BLAKE2B 88706cfc05ec1cc201f08e069dc6ad4f8e6fb49dbef5937208ba1e752e18b46639a5d32d4d0e270a0f2f6ed872aed70beeb2b0367d41fe443437331902a90bb2 SHA512 6328ad7e18b6fa982415b0de75e3384f58ce8428bd8c212871a31f3885a0819d241138d384b2e6d1b74a1d260229a027f9c1674a65f5b6c48e6b25e3024a0974
 DIST linux-5.4.3-arch1.i686.config 241295 BLAKE2B 795b6286bd1e7dc6aa5c1428e7bf08c204ce6c8cbee57863e9f64f8990790cc4398a7d062b54c89b1b80640f02a40fce028d9397725db0f968e8028b0611a20f SHA512 8c7387ded21c02b9cffee0e6d61a7040c44deae21764f743f7719f0d1c7adf684f6b62a501fe31709787ba741859e55fc3b8a3d3d27e52c09f2d8604212bf0a7
 DIST linux-5.4.7.arch1-1.amd64.config 241598 BLAKE2B 536cce5cc23cf20e71cba7468a125557f85d8ffc3cb194dced79bd489d39f2e4ed3960816d15d1491007d11b3af466e0a74267f983dfcc5f511f9f566f7e9821 SHA512 8658db603e180c75caf76972d85ecf8a4e9c9cf6e047b4f9fc7cba0fa426f434361528c1c29b5580f116cdd23091bf9afb6635d751f3b90c4e968d16db90eac1
 DIST linux-5.4.7.tar.xz 109448088 BLAKE2B 70197bb6955253710be5b56660dd6e224d3415f9074afeac9525d28089a6c1aa307408cf6bf460370093b8d079837850136a06dee2f3203370ed6cd8ab4d6e66 SHA512 b3b6c843bb8210acf04d294887b527c2da10507ac731fe9f6f04cd21486d519cda5767a2ba094f10886717720ca3bd3dee22a650c213b7f8f6c1f825396dbed4
diff --git a/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.10.ebuild b/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.10.ebuild
deleted file mode 100644 (file)
index 0733939..0000000
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit kernel-build
-
-MY_P=linux-${PV}
-AMD64_CONFIG_VER=5.4.7.arch1-1
-AMD64_CONFIG_HASH=ff79453bc0451a9083bdaa02c3901372d61a9982
-I686_CONFIG_VER=5.4.3-arch1
-I686_CONFIG_HASH=076a52d43a08c4b3a3eacd1f2f9a855fb3b62f42
-
-DESCRIPTION="Linux kernel built from vanilla upstream sources"
-HOMEPAGE="https://www.kernel.org/"
-SRC_URI+=" https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
-       amd64? (
-               https://git.archlinux.org/svntogit/packages.git/plain/trunk/config?h=packages/linux&id=${AMD64_CONFIG_HASH}
-                       -> linux-${AMD64_CONFIG_VER}.amd64.config
-       )
-       x86? (
-               https://git.archlinux32.org/packages/plain/core/linux/config.i686?id=${I686_CONFIG_HASH}
-                       -> linux-${I686_CONFIG_VER}.i686.config
-       )"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
-       !sys-kernel/vanilla-kernel-bin:${SLOT}"
-
-pkg_pretend() {
-       mount-boot_pkg_pretend
-
-       ewarn "This is an experimental package.  The built kernel and/or initramfs"
-       ewarn "may not work at all or fail with your bootloader configuration.  Please"
-       ewarn "make sure to keep a backup kernel available before testing it."
-}
-
-src_prepare() {
-       default
-
-       # prepare the default config
-       case ${ARCH} in
-               amd64)
-                       cp "${DISTDIR}"/linux-${AMD64_CONFIG_VER}.amd64.config .config || die
-                       ;;
-               x86)
-                       cp "${DISTDIR}"/linux-${I686_CONFIG_VER}.i686.config .config || die
-                       ;;
-               *)
-                       die "Unsupported arch ${ARCH}"
-                       ;;
-       esac
-
-       local config_tweaks=(
-               # shove arch under the carpet!
-               -e 's:^CONFIG_DEFAULT_HOSTNAME=:&"gentoo":'
-               # we do support x32
-               -e '/CONFIG_X86_X32/s:.*:CONFIG_X86_X32=y:'
-               # disable signatures
-               -e '/CONFIG_MODULE_SIG/d'
-               -e '/CONFIG_SECURITY_LOCKDOWN/d'
-               # disable compression to allow stripping
-               -e '/CONFIG_MODULE_COMPRESS/d'
-               # disable gcc plugins to unbreak distcc
-               -e '/CONFIG_GCC_PLUGIN_STRUCTLEAK/d'
-       )
-       sed -i "${config_tweaks[@]}" .config || die
-}